I've installed TexLive 2020 in Ubuntu 20.04(I've done an offline installation, if that matters). And as per the instructions on the TexLive doc page added the MANPATH, INFOPATH and PATH in my ~/.profile. But when I run latex --version in the terminal I get this: pdfTeX 3.14159265-2.6-1.40.20 (TeX Live 2019/Debian)

Can anyone help me with this?

  • Did you log out and in again? Profile is only read once per session. If you did please show exactly how you added the path
    – daleif
    Aug 4, 2020 at 15:20
  • @daleif it worked after I logged out and logged in again. Thanks. Aug 4, 2020 at 15:37
  • @daleif Didn't know that profile is read once per session. Thanks a bunch. Aug 4, 2020 at 15:38

1 Answer 1


On Linux the profile configuration file is only read as a part of the login procedure. This ensures that the settings set up in the profile can be seen by all subsequent processes, for example the PATH change can now be seen by any editor you open.

Thus when ever you have changed the profile, log out and in again for it to take affect.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .