1

iam still a new user to Latex and currently iam writing my master thesis with it, I use Texmaker. I divided my work into several files, and load each chapter with the \input{chapters/File name} command in my main.tex file. It was much effort and work for me to get the basics and the whole configuration set up as I need it, however, starting from today I got problems.

At some point the Quick build function kept loading, and loading and loading. After a while I decided to close Texmaker then. The language of the user interface changed to German although I did not initiate that. As I wanted to open again the main.tex file a message appeared:

"Error: File not found!"

Although it tells me, it did not find the file it loads it in. After pressing "Ok", the right half of the window (pdf.tex) gets visible and the message comes again. When I press "Ok" again, it seems that I can do something. A quick build however does not work, no error comes, but it just never terminates. When I try BibTex in order to get a hint what is wrong, it tells me this:

INFO - This is Biber 2.14 INFO - Logfile is 'Main.blg' ERROR - Main.bcf is malformed, last biblatex run probably failed. Deleted Main.bbl INFO - ERRORS: 1

Process exited with error(s)

I have no idea what is wrong, I did actually not change anything, just at some point during my work quick build did no longer work, and the PDF File seems to be empty, what is very strange. I tried to delete auxilliary files and rerun, but it still not work. Also I did a new folder and copied the .tex files, now I get the error that the input files cannot be found, although it works in my main folder, strange thing.

The .synctex(busy) I have deleted, but then a new one is generated. Also I realized my CPU is between 90 and 100% (I do not know if that is normal, I never checked before). I do not want to reinstal it, as I think it probably might not be necessary. In the internet I was not able to find a proper solution for my problem and hope the best here. I would be very thankful if you can help me. Please let me know if you need any kind of additional information.

Kind regards,

Niklas

7
  • 1
    don't use quick build if something goes wrong, that is trying to do a number of steps and if something goes wrong, it is difficult to debug. Use only pdflatex and check if it works. And try to find out what is wrong before changing something. Aug 4, 2020 at 15:23
  • Hey, thank you for your quick answer. Compiling the code with pdflatex yields the same problem as quick build does, it just never terminates.
    – Niklas
    Aug 4, 2020 at 15:25
  • then you probably inserted some looping code somewhere, that can happen. Move \end{document} up to some earlier place in your document to find the problematic code. Aug 4, 2020 at 15:28
  • .synctex(busy) reappearing and your CPU being over 90% suggests that something is still trying to build in the background. You'll want to stop that process.
    – Teepeemm
    Aug 4, 2020 at 15:28
  • I was doing a complex equation with cases included. As I wanted to recompile the problem started (other cases before I had no problems). I restarted my Laptop several times, and I tried to run the main.tex without the chapters, still it is just loading...
    – Niklas
    Aug 4, 2020 at 15:32

1 Answer 1

1

Update:

Guys I found a solution!

First of all I want to thank each of you, but especially Ulrike for this simple but nice trick with moving the end of the document to localize the error.

Indeed, the problem had its origin in the equation mentioned I was writing. I forgot a "}" after \frac. However, I wonder the program got "killed" by that. Normally I get an error message and I correct it. Anyhow, iam very glad to have this problem now solved.

Have a nice day and kind regards,

Niklas

1
  • Glad you were able to figure it out. Unfortunately, TeX is notorious for having unhelpful error messages.
    – Teepeemm
    Aug 4, 2020 at 20:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .