0

I do now know how to show Translated Title in the square brackets right before the dot, meaning that the translation would be in the same section with the title but not in italics.

It should look like this. Whatever I try separates the Translated title from the original one.

Author Last Name, First Name. Original Title [Translated Title]. City of Publication: Publisher, Year Published.

Chicago style citation example:

de Saint-Exupéry, Antoine. Le Petit Prince [The Little Prince]. Paris: Gallimard, 1943.

The packages that I use:

\usepackage[english]{babel}

\usepackage{csquotes}

\usepackage[notes,backend=biber]{biblatex-chicago}

UPDATE:

Thank you for you contribution, however, it does not do the exact formating that I need. I must stick to the example that I have given you. However, there is the thing that I come up with (not very convinient tho)

@book{krasnov,
    address = {Berlin},
    title = {Za chertopolokhom. Fantasticheskii roman \mkbibemph{[Behind the Thistle: a Fantastic Fiction]}},
    shorttitle      = {Za chertopolokhom},
    publisher = {Diakov},
    author = {Krasnov, Petr},
    date = {1922}
}

The end result

1

Turning @moewe's comment into an answer. I think this method is to be preferred. It is almost always a bad idea to insert formatting commands into .bib entries. This defeats the whole purpose of the .bib file being a repository of format-independent data which will be formatted according to the style chosen in the document. When you add formatting information to the .bib file you lose that independence. Additionally, it correctly attaches some semantics to the title translation (i.e., it's a separate element from the title itself.)

\documentclass{article}
\begin{filecontents}[overwrite]{\jobname.bib}
@book{petitprince,
    title={Le Petit Prince},
    titleaddon={The Little Prince},
    author={de Saint-Exupéry, Antoine},
    location={Paris},
    publisher={Gallimard},
    year={1943}
}
    @book{krasnov,
    address={Berlin},
    title={Za chertopolokhom},
    subtitle={Fantasticheskii roman},
    titleaddon={Behind the Thistle: a Fantastic Fiction},
    publisher={Diakov},
    author={Krasnov, Petr},
    year={1922}
}

\end{filecontents}
\usepackage{csquotes}
\usepackage[notes,ptitleaddon=space, ctitleaddon=space,useprefix=true]{biblatex-chicago}
\DeclareFieldFormat{titleaddon}{%
   \mkbibbrackets{\ifcapital{\MakeCapital{#1\isdot}}{#1\isdot}}}
\addbibresource{\jobname.bib}
\begin{document}
\cite{petitprince,krasnov}
\printbibliography
\end{document}

output of code

| improve this answer | |
  • Would it be wise then to delete my answer so nobody gets confused in the future? – phil-elkabat Aug 6 at 14:18
  • @phil-elkabat The first part of your answer provides an alternative, and although it's not what the OP is requesting, it might help others. So rather than delete your whole answer, perhaps just remove the second part that puts formatting into the .bib file. – Alan Munn Aug 6 at 14:34
  • Thank you, will do! – phil-elkabat Aug 6 at 14:40
  • I know this comes from the example in the question, but one can avoid the repetition of Za chertopolokhom in the .bib file by using the title and subtitle field: title={Za chertopolokhom}, subtitle = {Fantasticheskii roman}, – moewe Aug 6 at 14:52
  • @moewe Good point. That also removes punctuation from the title, which is probably wrong anyway, since a colon is the usual punctuation for subtitles and adding that field gets it right. I've updated the answer. – Alan Munn Aug 6 at 14:57
1

Update

Thanks to moewe's excellent comments, I've been able to vastly improve my answer – thank you!

Better reference the original title

The biblatex-chicago manual (p. 53) is quite clear on this:

The origtitle field isn’t used, while the language and origdate fields have been press-ganged for other duties. The origlanguage field,for its part, retains a dual role in presenting translations in a bibliography. The details of the Manual’s suggested treatment when both a translation and an original are cited may be found below under userf. Here, however, I simply note that the introductory string used to connect the translation’s citation with the original’s is “Originally published as,” which I suggest may well be inaccurate in a great many cases […]

So the preferred way to do this is with a construction like this: The original French book preceded by the English translation you're actually using. You can use the related={petitprince} option to make the relation clear:

@book{littleprince,
  address={New York},
  author={de Saint-Exupéry, Antoine},
  publisher={Reynal \& Hitchcock},
  title={The Little Prince},
  year={1943},
  related={petitprince},
}

@book{petitprince,
  title={Le Petit Prince},
  author={de Saint-Exupéry, Antoine},
  publisher={Gallimard},
  year={1943},
}

And then quoting like \cite{littleprince} which would give you this:

Originally published as

| improve this answer | |
  • Unless you plan to \nocite{*} the options={dataonly}, in petitprince shouldn't be needed - in fact it actively stops you from being able to cite petitprince in its own right. – moewe Aug 6 at 8:08
  • Re your code example for the second solution, you don't need \usepackage{etoolbox,keyval,ifthen,url}. Those packages are automatically loaded by biblatex (and thus also by biblatex-chicago since it loads biblatex). \usepackage{filecontents} is deprecated in new LaTeX versions (after October 2019). Usually people use \jobname.bib as filename, which will expand to the name of the .tex file being processed and thus give the .bib the same base name as the .tex file. jobname.bib will just call the file jobname. ... – moewe Aug 6 at 8:12
  • ... Strictly speaking \bibliography{jobname.bib} is incorrect: \bibliography takes the file name without the .bib file extension. But on all modern TeX systems the file will still be found (until recently this was not the case in MikTeX). \bibliography{jobname} without .bib would be correct. But in biblatex \addbibresource is preferred over \bibliography and that command needs the file extension. So I'd replace \bibliography{jobname.bib} with \addbibresource{jobname.bib}. – moewe Aug 6 at 8:14
  • Not sure if you are interested in looking at it, but my first thought would have been to use titleaddon. A quick test shows that the formatting isn't quite what the OP hoped for, but it should be possibly to adapt it (though that could get a bit ugly with a highly specialised style such as biblatex-chicago). (I don't have the time to look into that more closely at the moment, so feel free to include that in your answer.) – moewe Aug 6 at 8:17
  • 1
    Sorry if my answer was discouraging. I usually comment too, but there was one comment of yours (now sensibly deleted) that seemed to imply you weren't inclined to follow @moewe's suggestion more, so I added it as a separate answer. Without that comment I would probably have waited. – Alan Munn Aug 6 at 21:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.