0

I type this footnote

\documentclass[english]{article}
\usepackage[T1]{fontenc}
\usepackage[latin9]{inputenc}
\usepackage{setspace}
\usepackage{babel}
\begin{document}
\begin{doublespace}
Hi \footnote{\begin{singlespace}
Footnote content.
\end{singlespace}
}
\end{doublespace}
\end{document}

Then I get that weird space when I convert this to pdf. This is probably because my main text is double-spaced and footnote is single-spaced. But I want to keep it that way. How can I remove that weird space in footnote?

enter image description here

5
  • tex.stackexchange.com/a/32281/134144 could be interesting. – leandriis Aug 8 '20 at 5:39
  • As leandriis says: With setspace the footnotes are single-spaced anyway, so you don't need \begin{singlespace}...\end{singlespace}. Just try it. I usually find it easier to load setspace as \usepackage[doublespacing]{setspace} rather than wrapping everything in \begin{doublespace}...\end{doublespace}. – moewe Aug 8 '20 at 6:24
  • If you are interested why you get the undesirable output: It is caused by the fact that \begin{singlespace}...\end{singlespace} does some adjustments with \baselineskip spaces at \begin{singlespace}. That causes the unwanted space here. – moewe Aug 8 '20 at 6:28
  • @moewe @leandriis Thank you. I think I am approaching a solution. But when does LaTeX Error: Option clash for package setspace happen? – user1849133 Aug 8 '20 at 7:15
  • In this example you can only get a setspace option clash if you load setspace twice. In your real document there may be other packages or classes that load setspace for you. (Or you load it twice in your preamble.) Impossible to say without seeing the document that reproduces the error. – moewe Aug 8 '20 at 7:21
1

I am certainly missing something here. To me getting rid of most of your spacing commands is key. If not, let me know in the comments:

\documentclass[english]{article}
\usepackage[T1]{fontenc}
% \usepackage[latin9]{inputenc}
\usepackage[doublespacing]{setspace}
\usepackage{babel}
\usepackage{blindtext}

\begin{document}

Hi \footnote{\blindtext}
\blindtext[3]

\end{document}

Footnote spacing

2
  • Removing \doublespacing and loading setspace as \usepackage[doublespacing]{setspace} might be even nicer. (The effect is of course the same.) – moewe Aug 8 '20 at 12:41
  • @moewe, way nicer! So nice in fact, I'll shamelessly update my answer with your comment. There, I've said it. Thanks a bunch, moewe! – phil-elkabat Aug 8 '20 at 12:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.