I would like to use the LaTeX class provided by the editor Wiley to write a scientific article. Everything works well, except the Lato fonts used by this class: some of them are not available on my computer, and are replaced by quite ugly-looking fonts.

The fonts provided by Wiley are available here, in the folder lato-fonts. There is a Windows installer for those fonts, but unfortunately no instruction at all for Linux users (I'm under Linux Manjaro, with TeXLive 2020).

Installing the Manjaro package ttf-lato was unhelpful. I also tried those instructions from the lato-fonts folder, but they did not help:

sudo cp lato.sty /etc/texmf/tex/generic/misc/
sudo cp *.ttf /usr/share/fonts/TTF/
sudo texhash

Is there any proper way to install those Lato fonts "by hand"?


  • 1
    @DavidCarlisle no these are type1 fonts, with lots of tfm, vf etc, but sadly no tds structure. So the instruction is "put everything in the right place ;-)" Aug 13 '20 at 10:44
  • @DavidCarlisle I doubt that it will work with this class. Aug 13 '20 at 10:56
  • Indeed, it did not work ;) I'm currently struggling to find the right place for each of those files (e.g. using this: tug.org/fonts/fontinstall.html#fndb), but I'm still far from a solution. (And, sadly, now the unfound fonts are not simply replaced by standard fonts: there are blocking compilation errors.)
    – Philopolis
    Aug 13 '20 at 11:25
  • There is a Makefile with an install target, that seems to generate a TDS in $TEXMFHOME and copy all the fonts in the right places. Doesn't that work?
    – DG'
    Aug 13 '20 at 11:28
  • 3
    Move the tfm,pfb,vf,fd, sty,map files to your texmfhome into suitable subfolders, e.g. the tfm should go to /fonts/tfm/lato, check texmf-dist to guess the folders, normally it is quite obvious., add \pdfmapfile{=lato.map} to your document and try if it works. Aug 13 '20 at 12:12

From @Ulrike Fischer's answer, I tried to guess the right place for each type of file. For me, the following worked, and allowed a proper compilation of the .tex document:

# Make local directory:
mkdir ~/texmf/ -p

# .tfm files:
mkdir ~/texmf/fonts/tfm/lato/ -p
cp *.tfm ~/texmf/fonts/tfm/lato/

# .afm files:
mkdir ~/texmf/fonts/afm/lato/ -p
sudo cp *.afm ~/texmf/fonts/afm/lato/

# .pfb files:
mkdir ~/texmf/fonts/type1/lato/ -p
cp *.pfb ~/texmf/fonts/type1/lato/

# .vf files:
mkdir ~/texmf/fonts/vf/lato/ -p
cp *.vf ~/texmf/fonts/vf/lato/

# .fd files:
mkdir ~/texmf/tex/latex/lato/ -p
cp *.fd ~/texmf/tex/latex/lato/

# .sty file:
cp *.sty ~/texmf/tex/latex/lato/

# .map file:
mkdir ~/texmf/fonts/map/fontname -p
cp *.map ~/texmf/fonts/map/fontname

# .etx files:
mkdir ~/texmf/tex/fontinst/latinetx/ -p
cp *.etx ~/texmf/tex/fontinst/latinetx/

# .mtx files:
mkdir ~/texmf/tex/fontinst/latinmtx/ -p
cp *.etx ~/texmf/tex/fontinst/latinmtx/

# .enc files:
mkdir ~/texmf/fonts/enc/dvips/lato -p
cp *.enc ~/texmf/fonts/enc/dvips/lato

# Final config:
sudo texhash
sudo updmap-sys --force --enable Map=lato.map
sudo texhash

Just in case it would be useful for someone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.