0

I'm using TeX Live 2019 with LaTeX compiler (in Overleaf). I have the following code:

\documentclass[border=2mm]{standalone}

\usepackage[many]{tcolorbox}

\begin{document}
\tcbox[enhanced,drop fuzzy shadow ]
    {This is a tcolorbox.}
\end{document}

but I obtained

enter image description here

By using pdfLaTeX compilation with TeX Live 2019 or LaTeX compilation with Tex Live 2017, I obtain the right result:

enter image description here

What could be the problem? How can I fix it?

7
  • 1
    With recent MikTeX installation (pdfTeX, Version 3.14159265-2.6-1.40.21 (MiKTeX 20.7)) i obtain right result. You probaly need to upgrade your TeX Live to version 2020. – Zarko Aug 15 '20 at 5:39
  • @Zarko I'm using Overleaf – MateAndres Aug 15 '20 at 5:50
  • Ah, Overleaf is not always up-to-date with packages versions.Unfortunately. – Zarko Aug 15 '20 at 6:00
  • Does latex mean you are using dvips and ps2pdf? – Ulrike Fischer Aug 15 '20 at 7:39
  • @Zarko It's not a package problem, it's a Ghostscript problem (tex.stackexchange.com/questions/453780/…) – MateAndres Aug 15 '20 at 19:27
0

I copy here the answer from Overleaf Support:

You should be able to allow transparency by adding a new file latexmkrc (without any file extension) into your project's top folder and adding the following line there:

$dvipdf = "dvipdf -dNOSAFER -dALLOWPSTRANSPARENCY %O %S %D";

Note that you shouldn't include these options when you're running the code locally on your machine, as they are considered a security threat. In Overleaf, we run the compilations in isolated Docker containers, so there's no issue.

This is necessary in all TeX Live images in Overleaf up to 2019. For our TeX Live 2020, we're checking options how to allo transparency in PSTricks by default.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.