4

Tried looking this up, but having trouble finding anything that was helpful.

I just recently built a new computer and installed MikTex on this new desktop. I took a file that compiled on my previous desktop and struggled to get it to compile on this new desktop. I kept getting the error:

File "thmtools.sty" not found

I go into the MikTex console and look it up under packages and made sure it was installed. I tried restarting my computer, reinstalling the package, etc, but the error kept popping up. When finally looking into my files, I found the thmtools file, which does not contain any sty files. (It only downloaded dtx files.) I went to CTAN to manually download the tex files. I found the sty files. I couldn't get it to work in the MikTex files, but I DID get it to compile in the folder itself with the tex file I was creating by pasting all of the sty files from thmtools. There are so many .sty files in that folder right now from this quick workaround.

I've ran into this issue before on my previous computer. I'm wondering if there's a better and more permanent way to fix this so that I don't just end up with a massive amount of .sty files. I always just copy and paste from my previous folder when creating a new one.

  • 3
    Hello I'm the current maintainer of thmtools. When uploading thmtools v0.72 to CTAN, I made a mistake to not pack the .ins file. This mistake will prohibit getting .sty from .dtx, hence caused your problem on MiKTeX. On CTAN file .ins is back on around Aug 3, and I've reported this to MiKTeX, github.com/MiKTeX/miktex-packaging/issues/186. (The better and more permanent way is to wait MiKTeX to fix this problem caused by myself.) Sorry for the inconvenience. – muzimuzhi Z Aug 15 at 4:48
  • 2
    Oh I see! Thanks for the response and details! Also, thanks for maintaining the package =). I can just keep the .sty files inside the folder for now. That's always a nice and easy quick fix =). – Ecoi Aug 15 at 5:03
  • 1
    I am getting the same error too! File 'thmtools.sty' not found. Perhaps the best as said is to keep the thmtools.sty files inside the working folder and then wait for MiKTeX fix. – hesham Aug 15 at 17:41
  • 1
    @Ecoi @hesham MiKTeX has fixed the problem, you can try to upgrade thmtools. – muzimuzhi Z Aug 18 at 13:56
  • This is the latest version available on CTAN 72 2020-08-01 . Do you mean this or otherwise? – hesham Aug 18 at 14:25
2

As mentioned in my comment, this is a problem caused by wrongly packed thmtools (which was packed by myself). Thanks to Christian Schenk, the maintainer of MiKTeX, it has been resolved on Aug 18, 2020 (check here to see the .sty files are back).

| improve this answer | |
  • 1
    This is CTAN page that get ctan.org/pkg/thmtools?lang=en . The latest update date says 72 2020-08-01 – hesham Aug 18 at 15:28
  • 1
    [UPDATE] The Miktex has updated successfully to the thmtools version 2020-08-17. Now any source containing \usepackage{thmtools} compiles successfully. Thanks for the maintainer and the OP. – hesham Aug 18 at 15:33
  • 2
    @hesham Yes it is thmtools 72 2020-08-01. You can think that there was a wrong upgrade to thmtools 72 provided by MiKTeX, and now it is fixed without bumping the version number. – muzimuzhi Z Aug 18 at 15:56
  • I got it. Thanks. I just got confused between Aug 1 and Aug 18. – hesham Aug 18 at 21:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.