17

Recently I tried to reinstall the MathTimePro II fonts in my local texmf directory. I already have Lucida fonts installed which works fine. So I carefully copied all the relevant files/folders to the directories, added the new Map entry in the local updmap.cfg file and executed texhash/mktexlsr and updmap-sys. However my new font does not work, I get the following error:

(/usr/local/texlive/2011/texmf-dist/tex/latex/base/article.cls
Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
(/usr/local/texlive/2011/texmf-dist/tex/latex/base/size10.clo))
(/usr/local/texlive/2011/../texmf-local/tex/latex/mtpro2/mtpro2.sty)
(./MTPro2 LaTeX test.aux)
[1{/Users/hesam/Library/texlive/2011/texmf-var/fonts/
map/pdftex/updmap/pdftex.map}] [2] [3] (./MTPro2 LaTeX test.aux)
kpathsea: Running mktexpk --mfmode / --bdpi 600 --mag 4+0/600 --dpi
2400 mt2exf gsftopk: fatal: map file `cid-base.map' not found.
mktexpk: don't know how to create bitmap font for mt2exf. mktexpk:
perhaps mt2exf is missing from the map file. kpathsea: Appending font
creation commands to missfont.log.  )

!pdfTeX error: /usr/texbin/pdflatex (file mt2exf): Font mt2exf at 2400
not foun d

==> Fatal error occurred, no output PDF file produced!

It knows where to find mtpro2.sty in the local directory but can't find the fonts which are basically next door!

I have gone through a lot of online remedies but none have helped. I even restored the pdftex to an older version and started all over. The problem seems to be that the pdftex.map file does not have the fonts despite there being a map entry for mtpro2.

PS: I am using TeXShop/TeXLive (2011) on OS X 10.6.

  • 2
    At first you shouldn't change updmap.cfg directly. In TeXLive you should use updmap-sys --enable Map=XXXX (or updmap --enable Map=XXXX). At second: The path of pdftex.map sounds a bit as if it is a local map generated by updmap (without -sys). Rerun updmap-sys (eventually with the option --verbose and check if it actually change the pdftex.map. – Ulrike Fischer May 15 '12 at 7:14
  • I added the map entry to my 'local' updmap.cfg, I did use updmap-sys as well and finally the option you recommend does not exist. – Hesam May 15 '12 at 8:03
  • 1
    Did you run updmap-sys and checked if it actually changed the pdftex.map (look e.g. a the file date)? – Ulrike Fischer May 15 '12 at 8:34
  • Yes everytime I run updmap-sys, pdftex.map gets rewritten (it also says the same in updmap-sys output: "Files generated: ...."). – Hesam May 15 '12 at 8:37
  • I did't ask if one pdftex.map is generated but if the pdftex.map mentioned in the log gets rewritten. Check the one in Users/hesam/Library/.... – Ulrike Fischer May 15 '12 at 8:46
23

The key is here:

[1{/Users/hesam/Library/texlive/2011/texmf-var/fonts/map/pdftex/updmap/pdftex.map}]

You have, on some occasion, run updmap (not updmap-sys) and your TeX system uses the generated pdftex.map sitting in your personal tree.

Remove that file, so that the TeX system will use the global pdftex.map file.

To be on the safe side, after removing the file run from the Terminal the following commands:

sudo tlmgr generate updmap
sudo updmap-sys --enable-map <name>.map

(Change <name> into the correct name of the file in the MTPro distribution.)

In any case, adding the line

\pdfmapfile{=<name>.map}

before \begin{document} should make pdfTeX able to find the correct map file.

  • I removed that one but it started using the other pdftex.map which is in usr/local/texlive/2011/texmf-var/fonts/map/pdftex/updmap. But this produces the same exact problem. Then I deleted this map file as well and now pdftex does not work anymore. – Hesam May 15 '12 at 9:33
  • @Hesam Of course, if you delete the global pdftex.map, pdftex won't be able to run. Try following the instructions I added. – egreg May 15 '12 at 9:41
  • 1
    In case of "Unknown option: enable-map", see tex.stackexchange.com/questions/51704/… for example with updmap-sys --enable Map=_font_.map – sdaau Oct 11 '14 at 22:39
0

As recommended by @jon in this post purge latex or all the version of latex entirely from your system and install again that did the job for me. After spending some time trying in vain for hours to get latex use the right updmap file, reinstall latex completely.

If you face the same problem I suggest this answer which guide you towards completely removing latex from your system.. Make sure to search and delete any file related to /texlive/year/ before installing latex again.

  • If you really have files under /texlive/YYYY/ then there is not something wrong with just your TeX installation. There is something serious wrong with your operating system. I assume you mean ~/.texliveYYYY/` or something in your home Library (MacTeX) . If so, deleting those files and NEVER USING updmap AGAIN is the key. There is no reason to reinstall TeX and doing so is completely pointless as it will have no effect at all. Please read tex.stackexchange.com/questions/255709/… if you are still around. – cfr Mar 12 '17 at 2:10
  • Where did I say that the files were under /texlive/YYYY/?. Don't assume things too quickly :-). I provided a solution that worked for me at the time. I just shared this knowledge. Very good for everyone if you have a better one. – DJJ Mar 12 '17 at 9:13
  • Hardly an assumption. I simply read your answer. You said Make sure to search and delete any file related to /texlive/year/ before installing latex again.You might also have meant something like /usr/local/texlive/YYYY. Still very different from /texlive/YYYY, though. – cfr Mar 12 '17 at 13:47
  • Removing texlive/YYYY, texlive/texmf-local and some other folders, and then re-installing MacTeX worked for me. I had another error afterwards, but installing getnonfreefonts resolved that. – ttq Aug 13 '18 at 13:48
-1

UPDATE

Everything below is wrong. To understand why, please read: Why shouldn't I use getnonfreefonts to install additional fonts? Why shouldn't I use updmap when installing or removing fonts?

Note that the script I originally used came from this post. DO NOT USE this original script. A safer and updated approach to installing Minion Pro can be found here.


OLD/IGNORE

I had a similar error when install MinionPro:

Library/texlive/2016/texmf-var/fonts/map/pdftex/updmap/pdftex.map}]
(./minionpro-test.aux)
kpathsea: Running mktexpk --mfmode / --bdpi 600 --mag 0+545/600 --dpi 545 MinionPro-Regular-Base-aa
mktexpk: don't know how to create bitmap font for MinionPro-Regular-Base-aa.
mktexpk: perhaps MinionPro-Regular-Base-aa is missing from the map file.
kpathsea: Appending font creation commands to missfont.log.

I found that updmap --enable MixedMap MinionPro.map was not sufficient. After reinstalling multiple times, I found that another run of updmap at the end did the trick.

   updmap --enable MixedMap MinionPro.map
   updmap

  • 2
    This is not correct. Minion Pro does not provide a MixedMap. This is for fonts which include source and scalable fonts. It is not a 'trick' to workaround whatever other problem you were experiencing. Note that if you are using TeX Live, you should NOT use updmap EVER unless you have absolutely no choice. If you have absolutely no choice, consider using a different font configuration rather than using this. – cfr Mar 12 '17 at 2:07
  • 1
    Please read tex.stackexchange.com/questions/255709/…. – cfr Mar 12 '17 at 2:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.