0

I have found answers to similar questions but none solved my problem. I am not able to get references in a document produced by elsarticle.

For example I fail getting the references when doing as in the following question. elsarticle and natbib problem

But when running BibTeX I get the error message: ERROR - Cannot find control file 'documentname.bcf'! - did you pass the "backend=biber" option to BibLaTeX? INFO - ERRORS: 1

I have the same problem when running the template provided by Elsevier.

5
  • 1
    (1) welcome to the site, (2) please provide a full but minimal example of what you are doing. It is pretty clear from that message that you are using biblatex but that is not listed elsewhere in your question. And if you are using biblatex you should not also be using natbib. Additionally, if this is going to be sent to Elsevier, I'd double check if biblatex is something they support. – daleif Aug 20 '20 at 12:56
  • 1
    The elsarticle document class loads the natbib package automatically. natbib is not compatible with biblatex, though. By implication, the elsarticle document class is not compatible with biblatex. Does your document preamble maybe contain an instruction such as \usepackage{biblatex}? – Mico Aug 20 '20 at 13:24
  • On Elsevier templates with natbib you need to run BibTeX instead of Biber. The error message you quote is from Biber and not from BibTeX. Presumably you need to tell your editor to run BibTeX instead of Biber, sort of tex.stackexchange.com/q/154751/35864 in reverse. – moewe Aug 20 '20 at 15:25
  • Probably nonatbib option (\documentclass[nonatbib]{elsarticle}) should help to skip loading natbib package. – Sunilkumar KS Aug 21 '20 at 7:59
  • Thank you @moewe this worked for me. You can promote your comment to an answer. – DFL Aug 21 '20 at 13:28
2

The Elsevier templates don't use biblatex, usually they load natbib by default. I don't think it is advisable to try and use biblatex with elsarticle or any other Elsevier template.

That means that you need to compile your document with BibTeX and not with Biber. Tell your editor to run BibTeX instead of Biber. (I.e. do Biblatex with Biber: Configuring my editor to avoid undefined citations in reverse.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.