0

I want to use the \todonodes package, but at the moment, the layout drives my crazy. The End of the "todo" line does not align with the text. I don't know how to describe it better, please see the screenshot enter image description here

Here is my Code

\documentclass[
    12pt,
    a4paper,
    headinclude,
    footinclude,
    listof=totoc,
    toc=sectionentrywithdots,
    bibliography=totoc
    ]{scrartcl}
\usepackage[utf8]{inputenc}
\usepackage[ngerman]{babel}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage[onehalfspacing]{setspace} % 1,5facher Zeilenabstand 
\usepackage[a4paper, top=3cm,bottom=3cm,left=4.5cm,right=2cm]{geometry} 
\usepackage{graphicx}
\usepackage{parskip} %Abstand zwischen Abständen
\setlength\parindent{0pt} %Einzug neuer Absatz unterbinden
\usepackage[]{acronym} % Abkürzungen 
\usepackage{float}
\usepackage[colorinlistoftodos, ngerman]{todonotes}\setlength{\marginparwidth}{3cm}\reversemarginpar
\usepackage{microtype}
%\usepackage{showframe}

%Literaturverzeichnis Pakete + Anpassungen am Erscheinungsbild
\usepackage[
    style=authoryear,
    autocite=footnote,
    maxcitenames=3,
    mincitenames=3,
    maxbibnames=8,
    minbibnames=8,
    ]{biblatex}
    
\usepackage[babel, german=guillemets]{csquotes}  

\addbibresource{literatur.bib} % Datei mit Literaturverzeichnis

\renewcommand*{\newunitpunct}{\addcomma\space}
\renewcommand*{\finentrypunct}{}

\DeclareFieldFormat[book]{title}{\mkbibquote{#1\isdot}}

\DeclareNameAlias{default}{family-given}
\DeclareNameAlias{sortname}{default}

\DeclareListWrapperFormat{location}{\mkbibparens{#1}}

\DefineBibliographyStrings{german}{
  andothers = {et al\adddot},
  nodate    = {o.J\adddot},
}

\DeclareDelimFormat{nameyeardelim}{\addcomma\space}
\DeclareDelimFormat[bib]{nameyeardelim}{\addcomma\space}

\renewbibmacro*{cite:label}{%
  \printtext[bibhyperref]{\printfield{label}}}
    
\newbibmacro*{cite:labeltitle}{%
  \printtext[bibhyperref]{\printfield[citetitle]{labeltitle}}}

\renewbibmacro*{cite}{%
  \iffieldundef{shorthand}
    {\ifthenelse{\ifnameundef{labelname}}
       {\usebibmacro{cite:label}%
        \setunit{\printdelim{nonameyeardelim}}}
       {\printnames{labelname}%
        \setunit{\printdelim{nameyeardelim}}}%
     \ifboolexpr{   test {\iffieldundef{labelyear}}
                 or test {\iffieldequalstr{labelyear}{nodate}}}
       {\usebibmacro{cite:labeltitle}}
       {\usebibmacro{cite:labeldate+extradate}}}
    {\usebibmacro{cite:shorthand}}}

\setlength\bibitemsep{1.5\itemsep}


\begin{document}
\tableofcontents
\setcounter{page}{1}
%Abbilungsverzeichnis und Tabellenverzeichnis einfügen
\newpage
\listoffigures
\newpage
\listoftables
\newpage
\section{Abkürzungsverzeichnis}
\begin{acronym}[Bash]
 \acro{JK-FlipFlop}{Jack Kilby FlipFlop}
\end{acronym}

\newpage



%Beginn der Einleitung
\section{Einleitung} 
\todo{test}
 Das Ziel dieses Assigments ist es, \todo[]{Einleitung überarbeiten} einen synchronen  

\end{document}
5
  • I don't get your output in a current texlive. Is your tex system up-to-date? Commented Aug 31, 2020 at 9:32
  • I'm using overleaf.com
    – wit4r7
    Commented Aug 31, 2020 at 9:35
  • I checked this template in overleaf de.overleaf.com/latex/examples/… and it works as it should. So I think there is a problem in my settings.
    – wit4r7
    Commented Aug 31, 2020 at 9:41
  • I tried your example on overleaf and it doesn't show you output there either. Commented Aug 31, 2020 at 9:42
  • Well, thanks for your effort. I will try to find the problem with my code.
    – wit4r7
    Commented Aug 31, 2020 at 9:57

1 Answer 1

0

Well, I found my problem.

I have excluded the preamble into a separate file. And for some reasons the import causes the problem.

If I use the \usepackage[colorinlistoftodos, ngerman]{todonotes}\setlength{\marginparwidth}{3cm}\reversemarginpar directly in my main file everything works as aspected.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .