0

I need my bib file to be ASCII encoded so that it works when Lyx invokes Bibtex for my bibliography and referencing. However within TeXShop on my mac I can't find the option to encode in ASCII. UTF-8 does not work. What do i need to do to have it encode in ASCII

3
  • 3
    I can't help with texshop but utf8 and ascii are the same thing in the ascii range so if you only write it using ascii, so {\'e} not the accented letter, it doesn't matter if it is saved as utf-8 or ascii as there is no difference. Commented Aug 31, 2020 at 22:54
  • It would be simpler to invoke biber, which understands utf8.
    – Bernard
    Commented Aug 31, 2020 at 23:11
  • See also How to write “ä” and other umlauts and accented letters in bibliography for more information on how to input "accented characters" in a bib file for processing with BibTeX.
    – Mico
    Commented Sep 1, 2020 at 5:14

1 Answer 1

1

There is no setting for ASCII but you must make sure you only type characters that are in the ASCII set; e.g., you can only type accented characters using macros (e.g., \'e instead of é directly) since accented characters are not part of the ASCII set. Please read theHelp->File Encoding and TeXShop document for more information. Most single byte encodings and UTF-8 Unicode actual have ASCII as a subset.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .