1

When I use pdflatex test.tex to compile the simple file:

\documentclass{article}
\begin{document}
Hello \S world! 
\end{document}

the symbol \S is rendered using the (rasterized) T3 font:
<C:\Users\laure\AppData\Local\MiKTeX\fonts/pk/ljfour/jknappen/ec/dpi600\tcrm100 0.pk>

whereas the rest of the text is rendered using the standard LaTeX font
<C:/Program Files/MiKTeX/fonts/type1/public/amsfonts/cm/cmr10.pfb> enter image description here

What is the reason for this? There seems to be no problem when I use e.g. Overleaf to compile this file. Here is test.log:

This is pdfTeX, Version 3.14159265-2.6-1.40.21 (MiKTeX 20.7) (preloaded format=pdflatex 2020.9.2)  3 SEP 2020 18:24
entering extended mode
**./test.tex
(test.tex
LaTeX2e  patch level 5
L3 programming layer 
("C:\Program Files\MiKTeX\tex/latex/base\article.cls"
Document Class: article 2019/12/20 v1.4l Standard LaTeX document class
("C:\Program Files\MiKTeX\tex/latex/base\size10.clo"
File: size10.clo 2019/12/20 v1.4l Standard LaTeX file (size option)
)
\c@part=\count168
\c@section=\count169
\c@subsection=\count170
\c@subsubsection=\count171
\c@paragraph=\count172
\c@subparagraph=\count173
\c@figure=\count174
\c@table=\count175
\abovecaptionskip=\skip47
\belowcaptionskip=\skip48
\bibindent=\dimen134
)
("C:\Program Files\MiKTeX\tex/latex/l3backend\l3backend-pdfmode.def"
File: l3backend-pdfmode.def 2020-08-07 L3 backend support: PDF mode
\l__kernel_color_stack_int=\count176
\l__pdf_internal_box=\box45
)
No file test.aux.
\openout1 = `test.aux'.

LaTeX Font Info:    Checking defaults for OML/cmm/m/it on input line 2.
LaTeX Font Info:    ... okay on input line 2.
LaTeX Font Info:    Checking defaults for OMS/cmsy/m/n on input line 2.
LaTeX Font Info:    ... okay on input line 2.
LaTeX Font Info:    Checking defaults for OT1/cmr/m/n on input line 2.
LaTeX Font Info:    ... okay on input line 2.
LaTeX Font Info:    Checking defaults for T1/cmr/m/n on input line 2.
LaTeX Font Info:    ... okay on input line 2.
LaTeX Font Info:    Checking defaults for TS1/cmr/m/n on input line 2.
LaTeX Font Info:    ... okay on input line 2.
LaTeX Font Info:    Checking defaults for OMX/cmex/m/n on input line 2.
LaTeX Font Info:    ... okay on input line 2.
LaTeX Font Info:    Checking defaults for U/cmr/m/n on input line 2.
LaTeX Font Info:    ... okay on input line 2.
[1

{C:/Users/laure/AppData/Local/MiKTeX/pdftex/config/pdftex.map}] (test.aux) ) 
Here is how much of TeX's memory you used:
 362 strings out of 481212
 6153 string characters out of 2915728
 241955 words of memory out of 3000000
 16035 multiletter control sequences out of 15000+200000
 535423 words of font info for 30 fonts, out of 3000000 for 9000
 1141 hyphenation exceptions out of 8191
 25i,4n,25p,141b,97s stack positions out of 5000i,500n,10000p,200000b,50000s
 
Output written on test.pdf (1 page, 13285 bytes).
PDF statistics:
 15 PDF objects out of 1000 (max. 8388607)
 0 named destinations out of 1000 (max. 500000)
 1 words of extra memory for PDF output out of 10000 (max. 10000000)
  • 2
    You should install the cm-super font package. That's a recurring issue with MiKTeX. – egreg Sep 3 at 22:32
  • @egreg According to Miktex, cm-super is installed (I did a full install of all packages). I tried invoking cm-super by adding \usepackage[T1]{fontenc} into the preamble, but that ended up rasterizing all the text. :-( – Laurent Lessard Sep 3 at 23:36
  • Loading \usepackage[T1]{fontenc} does not mean that it loads CM-Super. If CM-super is correctly installed it should replace the default font for more or less every setting. I can see that you have both user and admin parts of your MikTeX, perhaps one of them is overruling the other. – daleif Sep 4 at 7:05
  • if cm-super is installed but not used it probably means that you should recreate the font map files as user: miktex console (user mode), menu tasks. – Ulrike Fischer Sep 4 at 7:44
2

Thanks to everybody for the quick responses! The problem is resolved now. There were two causes.

  • I had installed MiKTeX using the "Install MiKTeX for anyone who uses this computer (all users)". The install guide recommends against this because it can be "complicated and error prone". They were right! This maintains two profiles and sets of packages that need to be kept in sync. I didn't realize that.
  • I had to install the cm-super package, which is not one of the standard packages that comes with a fresh MiKTeX installation. It really should be though...

After reinstalling MiKTeX using the "only for me" option and installing cm-super through the package manager, the same code I posted before compiled properly.

| improve this answer | |
  • 2
    I think Cm-super is about 200Mb which is probably why it is left out in mikrex. – daleif Sep 4 at 13:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.