0

I'm trying to write my first document with classicthesis (documentclass scrbook), but when I compile it, it looks like the top and bottom margins are somehow reduced to nearly 0: there is nearly no space between page number/chapter title/section title and the page edge.

I progressively removed every customization I used (a couple of classicthesis options and some other packages I loaded) until I only loaded classicthesis and put some contents:

\documentclass{scrbook}
\usepackage{classicthesis}

\usepackage{lipsum}

\begin{document}
\title{Title of the article}
\author{Author Name}
\maketitle

\chapter{Lorem ipsum}
\section{Foo}
\lipsum

\section{Bar}
\lipsum
\end{document}

However, when I compile it I always get this (note - I have not cropped the page):

enter image description here

I also tried to rebuild the setup used for the package manual by adding the drafting option, just to check if anything changed - and it didn't even print date and time at the bottom of the page.

As far as I know, this is not exactly what classicthesis should produce, but I can't figure out where is the problem. Any suggestion?

3
  • 1
    scrbook does not seem to cooperate well with classicthesis. (See the bunch of warnings you get when compiling your MWE). As fas as I can tell, there are two options: You can either stick to classithesis and instead use a documentclass such as book or you could use scrbook without the classicthesis package.
    – leandriis
    Sep 5 '20 at 9:25
  • @leandriis Thanks! I was compiling with TeXstudio and as the document was compiled anyway I missed all the warnings!
    – Ntakwetet
    Sep 5 '20 at 10:14
  • Nothing to worry about. Check the options to \documentclass in classicthesis-book.tex in the Examples folder that comes with the template. You need these two options: headinclude and footinclude. Sep 11 '20 at 0:04
0

Your \documentclass is missing two options: headinclude and footinclude. You'll find them in classicthesis-book.tex in the Examples folder that comes with the template.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.