2

This is an example test.tex document. Both babel and polyglossia failed and produce the same error:

\documentclass{book}

%\usepackage[vietnamese]{babel}
\usepackage{polyglossia}
\setdefaultlanguage{vietnamese}

\usepackage{biblatex}


\title{Sth}

\begin{document}

\maketitle

\end{document}

This is the full log. And my config for VS Code:

"latex-workshop.latex.recipes": [
    {
        "name": "lualatex->biber",
        "tools": [
            "lualatex",
            // "biber",
        ]
    }
],
"latex-workshop.latex.tools": [
    {
        "name": "lualatex",
        "command": "lualatex",
        "args": [
            "--shell-escape",
            "-synctex=1",
            "-interaction=nonstopmode",
            "-file-line-error",
            "-pdf",
            "%DOC%"
        ]
    },
    {
        "name": "biber",
        "command": "biber",
        "args": [
            "%DOCFILE%"
        ]
    }
],

I installed all Vietnamese-related package I found using tlmgr search, notably babel-vietnamese and vntex, to no avail.

When I use English language, it works. When I paste the exact document to Overleaf, it also works. So it's something on my part. How can I fix this?

1 Answer 1

4

That was a bug in biblatex v3.15 and v3.15a related to https://github.com/plk/biblatex/issues/945.

It was be fixed in biblatex v3.16 from 2020-12-31.

If you still have this problem, update your system.


Old answer in case you are stuck with an old version of biblatex that cannot be updated

For now you can manually define the undefined toggles that might be used (in your case the for the fallback emglish and for vietnamese).

\documentclass{book}

%\usepackage[vietnamese]{babel}
\usepackage{polyglossia}
\setdefaultlanguage{vietnamese}

\usepackage{biblatex}

\providetoggle{blx@lang@captions@english}
\providetoggle{blx@lang@captions@vietnamese}

\title{Sth}

\begin{document}

\maketitle

\end{document}

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .