1

I'm a low level user; I don't have administrative privileges though I could get some if I really needed to. I'm also a LateX novice; I have a background in math so I get the math symbol commands but I have zero background in setting up documents.

I'm writing a document using 12 point fonts for older eyes like mine. The math symbols generated are small and rather faint. I'd like to fix this with one document-wide command rather than individual commands because I have several inline short math objects.

I've tried inserting

[+preamble]
\DeclareMathSizes{12}{20}{14}{10}
[/preamble]

both before and after [latexpage] but it acts funny even in the editing page, generating isolated lines in boxes and I can't set the cursor outside one of those boxes.

Please give me detailed instructions for the simplest way to make math symbols larger and perhaps a bit bolder. I have multiple pages and it would be ok if it applied to all or I'm good with page by page. The administrator of my site has no experience in this nor is he a mathematician but he'd add something I cannot add if I gave him detailed instructions. Thanks!!

5
  • Welcome to TeX SE! While I can't explain why the font sizes aren't working for you, there is a place in the QuickLaTeX plugin's settings for creating a systemwide default preamble, and that would be where you put your command to make it work on every page. Commented Sep 13, 2020 at 22:00
  • Thank you. It would be very helpful if you'd explain in great detail just what should go just where. I lack the privileges and certainly the knowledge to be able to experiment fruitfully. :(
    – Neil Stahl
    Commented Sep 14, 2020 at 13:40
  • Or if there's a resource on the Web that would tell me those things?
    – Neil Stahl
    Commented Sep 14, 2020 at 13:41
  • I can provide a partial answer, showing how to set a systemwide preamble. However, note that one needs administrator access to the blog's control panel. Commented Sep 14, 2020 at 18:39
  • it just returns an image so it's probably simpler to adust the html in your blog <img height="120%" src="... will be bigger. Commented Oct 1, 2023 at 9:02

1 Answer 1

1

This is really only a partial answer, addressing how to set a systemwide preamble. To my knowledge, only the blog's owner or administrator can do this. First, log into the blog's control panel. Second, look for Plugins in the lefthand column menu, and select Installed Plugins. Find the entry for WP QuickLaTeX and select Settings. At the top left of the QuickLaTeX Settings page, select System. Select the checkbox for Use LaTeX Syntax Sitewide. This negates the need to put [latexpage] on individual pages. Ignore the Exclude $ .. $ setting, and look just below it. There is a large text entry window into which you can put your global preamble. For example, mine currently contains the following:

\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{amssymb}
\usepackage[boldvectors]{mandi}
\newcommand{\parallelto}{\ensuremath{{{\mkern3mu\vphantom{\perp}\vrule depth 0pt
  \mkern2mu\vrule depth 0pt\mkern3mu}}}}
\newcommand{\perpendicularto}{\ensuremath{\perp}}

Be sure to click one of the large blue rectangular Update QuickLaTeX Settings buttons to apply the updated settings.

Now, if you use [+preamble]...[/preamble] tag it will override the systemwide preamble.

There are two caveats. The first is that if you write [preamble] instead of [+preamble] the new preamble commands supersede those of the global preamble. If you write [+preamble] the new preamble commands are used in addition to those of the global preamble. The second is that the new preamble must be used inside of a block of LaTeX code, such as a math environment.

I regret that I have no solution to the font size issue. It doesn't seem to work for me either. By the way, the QuickLaTeX author is on TeX SE and sometimes responds to questions here.

2
  • Thank you! I think the administrator won't want to apply this throughout his site; very few of us are likely to use it. I could tell him it's not going to hurt anything but then it will cause something weird. I appreciate you being so detailed. Best wishes!
    – Neil Stahl
    Commented Sep 15, 2020 at 0:34
  • I wish I could have been of more help. Commented Sep 15, 2020 at 22:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .