1

Morning, I tried to make a simple grid and also drawing a line (handy-like). My lines are basic. I used MikTex with TexStudio. Compile is ok, a PDF is done but nothing on it, except the page numbering - in this case the "1". I'm out of clues...

Here is my code :

\documentclass[12pt]{article}
\usepackage{pstricks}
\usepackage{pstricks-add} %for the handy line

\begin{document}
    
    \begin{pspicture}(-1,-1)(2,1)
        \psgrid(-1,-1)(2,1)
    \end{pspicture}

    \begin{pspicture}(0,-0.5)(3,0.5)
        \pslineByHand(0,0)(3,0)
    \end{pspicture}

\end{document}

and the msg from system when compiled :

Process started: latex -src -interaction=nonstopmode "untitled-1".tex
Process exited normally

TiA.

4
  • Are you sure to compile with the DVI->DVIPS->PS2PDF mode ?
    – gigiair
    Commented Sep 13, 2020 at 7:15
  • Welcome to TeX SX! What if you try compiling with xelatex?
    – Bernard
    Commented Sep 13, 2020 at 8:24
  • Your code works fine for me. Please try your coding with either xeLaTeX or LaTeX -> dvips -> PS2PDF, if still the error exists then post your .log file details
    – MadyYuvi
    Commented Sep 13, 2020 at 11:44
  • Why not use auto-pst-pdf? Commented Sep 13, 2020 at 18:10

1 Answer 1

1

Ok. My bad. It was the compiling method i used. As comments told by other users above, I tried the DVI / PS / PDF and it works fine now. I think the process in TeXStudio is not as easy as it seems. I have not configured the app after the install, maybe it's the problem. Thank you all for your help.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .