1

I am making a beamer presentation where I would like to enter citation names in a table. I am using cite{bibid}. This is generating the citation inside round brackets which I would like to avoid. My preamble is

\documentclass{beamer}
\usepackage{csquotes}
\usepackage{ragged2e}
\usepackage{diagbox}
\usepackage{textcomp}
\usepackage{tabularx}
\usepackage{multirow}
\usepackage{array}
\usepackage{bibentry}
\usepackage{harvard}
\usepackage{bookman}
\newcolumntype{P}[1]{>{\centering\arraybackslash}p{#1}}
\usetheme{Singapore} 
\usecolortheme{beaver} 
\usefonttheme{structuresmallcapsserif}
\setbeamerfont{serif}{size=\large, series=\bfseries}
\AtBeginDocument{\usebeamerfont{structurebold}}

The table is

\begin{frame}[fragile]{\huge Literature Survey}
    \justifying
    \begin{table}
        \begin{tabular}{||P{25mm} | p{8cm} ||}
        \hline
         Author & \hspace{25mm}Key Findings \\\hline
         \cite{kawamura1998state} & bla bla bla\\\hline
         \cite{waag2014critical} & bla bla bla\\\hline
        \end{tabular}
        \caption{Triathlon results}
    \end{table}
\end{frame}

MWEB as requested:

\documentclass{article}


\begin{filecontents}{\irbref.bib}
@inproceedings{kawamura1998state,
    title={State of {C}harge {E}stimation of {S}ealed {L}ead-{A}cid {B}atteries {U}sed for {E}lectric {V}ehicles},
    author={Kawamura, Atsuo and Yanagihara, Takahiro},
    booktitle={PESC 98 Record. 29th Annual IEEE Power Electronics Specialists Conference (Cat. No. 98CH36196)},
    volume={1},
    pages={pp. 583--587},
    month={22 May 1998},
    address={Fukuoka, Japan},
    year={1998},
    organization={IEEE}
}

@article{waag2014critical,
    title={Critical {R}eview of the {M}ethods for {M}onitoring of {L}ithium-ion {B}atteries in {E}lectric and {H}ybrid {V}ehicles,},
    author={Waag, Wladislaw and Fleischer, Christian and Sauer, Dek Uwe},
    journal={Journal of Power Sources,},
    volume={258},
    pages={pp. 321--339},
    year={2014},
    publisher={Elsevier}
}
\end{filecontents}

\begin{document}

\cite{key}

\bibliographystyle{agsm3}
\bibliography{\irbref}

\end{document}

I edited the source code of default agsm package to get bold and italics to et al. and made the custom agsm3 style. Hope this helps.

12
  • 1
    Please prepare a complete minimal working example with bibliography (MWEB) that others can use to reproduce the same output you get.
    – leandriis
    Commented Sep 19, 2020 at 7:16
  • 1
    In particular, do please tell us which bibliography style you employ.
    – Mico
    Commented Sep 19, 2020 at 7:17
  • Observe also that your query -- how to prevent a citation call-out from being surrounded by round parentheses -- is not directly related to the fact that happen to be using the beamer document class. If you think that I'm mistaken, i.e., that the query truly has a beamer-specific component, please show where I went wrong.
    – Mico
    Commented Sep 19, 2020 at 7:24
  • If I remember correctly, the agsm bibliography style is introduced by the harvard package. According to its documentation, adding \harvardparenthesis{none} should help to remove the parentheses.
    – leandriis
    Commented Sep 19, 2020 at 7:30
  • 1
    @TamoghnaBhattacharya - If you use \citep in a different document (say, one that uses the report document class), it must be the case that that document loads the natbib citation management package, as the harvard citation management package does not define \citep.
    – Mico
    Commented Sep 19, 2020 at 7:33

1 Answer 1

1

The natbib citation management package works just fine with the beamer document class. For full compatibility with some of the bibliography styles -- such as agsm and dcu -- that are provided by the harvard citation management package, be sure to load har2nat as well. (This piece of advice is not specific to beamer.)

I would use \cite and \citep to create citation call-outs with parentheses and \citealp to create citation call-outs without parentheses.

enter image description here

\documentclass{beamer}

\usepackage{natbib,har2nat}
\setcitestyle{aysep={}} % optional
\bibliographystyle{dcu} % or some other suitable bib style

\begin{filecontents}[overwrite]{mybib.bib}
@misc{smith:01,author="Sam Smith",title="Thoughts",year=3001}
\end{filecontents}

\begin{document}
\begin{frame}
\cite{smith:01}, \citep{smith:01}, \citealp{smith:01}.
\end{frame}

\begin{frame}
\bibliography{mybib}
\end{frame}
\end{document}
3
  • I keep getting \citename already defined. \newcommand\citename{}. Just can't get around it. And things are getting increasingly weirder, I have 2 consecutive frames with citations, in the first one I am not getting 'et al.' format but on the second one I am getting it. There is no difference in the syntax amongst the 2 frames. Commented Sep 19, 2020 at 8:04
  • @TamoghnaBhattacharya - What are you trying to achieve by \newcommand\citename{}; why aren't you running \renewcommand\citename{}? Why are you trying to undefine \citename at all? (Sadly, but maybe not surprisingly, my divination skills are just rubbish.) The formatting issue that appears to be bugging you -- all authors listed the first time a piece is cited, first-author-et-al from the second time onward -- could be caused by you loading natbib with the option longnamesfirst. Is that the case? Please do provide more usable information about your document setup.
    – Mico
    Commented Sep 19, 2020 at 8:25
  • @TamoghnaBhattacharya - Note also that if a version of agsm is in use, the issue of getting a full list of authors in the first citation call-out and first-author-et-al the second time the piece is cited arises both if the harvard package is loaded and you use \cite to create citation call-outs (along with \harvardparenthesis{none} in the preamble) and if the natbib package is loaded with the option longnamesfirst and if you use \citealp to create citation call-outs. If you want et-al type citiation call-outs throughout, do not specify longnamesfirst.
    – Mico
    Commented Sep 19, 2020 at 8:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .