1

I used leipzig when typesetting my paper to get glossing abbreviations in smallcaps more easily and to automatically generate a glossary. However, I didn't get the package to work as it did for others. The glossing macros worked fine, but the glossary didn't appear (I used \footnote{\printglosses} and only a blank footnote appeared).

Does anyone know what the cause of this error is?

I then toyed with the minimal example in the package documentation, and the result was the same. I tried with another device (though same distribution [MikTeX] and editor [TeXworks]), and the result was still the same--could this be due to the editor?

There was a similar question (well, practically the same problem) a few years back:

Leipzig and glossaries: compatibility problems, and glossary does not appear

where the author of the package also commented. But there hasn't been any development for some time and there's really no solution yet, so I reckon I should post a separate one.

1
  • Follow suggestions in the question comments. For me, TeXlive 2020, it works as expected (I have used MWE from the linked question) – there is a footnote generated with description of "NOM." Sep 22, 2020 at 7:00

1 Answer 1

0

I had this exact same problem this week.

I am using the most recent versions of MacOS, MacTeX, TeXMaker, TeXLive/TeXLive Manager, and all my packages.

If you are on TeXMaker, go to User --> User Commands --> Edit User Commands then, after "menu item" type: Make Glossaries and after "command" type: makeglossaries % (the % here is important and refers to whatever file you are using).

Click "ok" and the screen should go away. The go to User --> User Commands --> Make Glossaries (click "Make Glossaries"). I do it twice just to be sure.

Then run everything like you normally would. For me, this was the trick that finally worked.

Note: you still need \makeglossaries in your preamble, I believe. You just also have to perform the steps above.

Remember to click "Make Glossaries" again if your running list of Abbreviations is not up-to-date.

Check out my similar recent question and the answers to it here: UPDATED: {leipzig} Package [still] Not Producing a Glossary

Hope this helps! :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.