0

As i mentioned below i'm using mongolian cyrillic and using template of IEEEtran and tried using

\tracinglostchars=2 % Warn if a font does not contain a character
\usepackage{tgtermes} % Times clone.
\usepackage[T1,T2A]{fontenc} % Select a Cyrillic encoding
\usepackage[utf8]{inputenc} % The default since 2018
\usepackage[english, main=mongolian]{babel}
\usepackage{substitutefont} % For \substitutefont
\babeltags{mongolian=mongolian} % Enable \textmongolian, \begin{mongolian}, etc.
\babeltags{english=english}
\usepackage{microtype} % Enable font expansion and protrusion.
\substitutefont{T2A}{\rmdefault}{Tempora-TLF} % Supplementary font for Cyrillic

i just added it on top of the code am i doing something wrong or am i so bad at it the example code worked fine when its added to IEEEtran template it wont work the log says

No declaration for shape T2A/Tempora-TLF/m/sc. \section*{Ажлын зорилго}
Font shape `T2A/qtm/m/n' undefined(Font) using `T2A/cmr/m/n' instead
Underfull \hbox (badness 1661) in paragraph
Underfull \vbox (badness 10000) has occurred while \output is active []
Some font shapes were not available, defaults substituted.
Label(s) may have changed. Rerun to get cross-references right.

And every package being used on the IEEEtran template plus the new codes

\documentclass[conference]{IEEEtran}
\IEEEoverridecommandlockouts
% The preceding line is only needed to identify funding in the first footnote. If that is unneeded, please comment it out.
\usepackage{cite}
\usepackage{amsmath,amssymb,amsfonts}
\usepackage{algorithmic}
\usepackage{graphicx}
\usepackage{textcomp}
\usepackage{xcolor}

\tracinglostchars=2 % Warn if a font does not contain a character
\usepackage{tgtermes} % Times clone.
\usepackage[T1,T2A]{fontenc} % Select a Cyrillic encoding
\usepackage[utf8]{inputenc} % The default since 2018
\usepackage[english, main=mongolian]{babel}
\usepackage{substitutefont} % For \substitutefont
\babeltags{mongolian=mongolian} % Enable \textmongolian, \begin{mongolian}, etc.
\babeltags{english=english}
\usepackage{microtype} % Enable font expansion and protrusion.
\substitutefont{T2A}{\rmdefault}{Tempora-TLF} % Supplementary font for Cyrillic



\def\BibTeX{{\rm B\kern-.05em{\sc i\kern-.025em b}\kern-.08em
        T\kern-.1667em\lower.7ex\hbox{E}\kern-.125emX}}

i dont see any compiling error at all. using TexStudio right now the error is always \section{} some reason it wont support mongolian cyrillic if its tempora-TLF

Orignal post: In MikTek, TexStudio cyrillic wont appear normal if its displayed its displaying question mark on pdf file "АБВГД"="?????" enter image description here

! Package inputenc Error: Unicode character ф (U+0444) (inputenc) not set up for use with LaTeX.

Using UTF-8 unicode tried others with Cyrillic support nothing major happened some dont compile some shows "?????"

Loading babel didnt fix the problem plus when i tried using windows-1258 there isnt any compiling error but enter image description here

  This is pdfTeX, Version 3.14159265-2.6-1.40.21 (MiKTeX 20.7)
entering extended mode
(C:/Users/mcmun/Documents/test.tex
LaTeX2e <2020-02-02> patch level 5
L3 programming layer <2020-09-03>
(C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/latex/ieeetran\IEEEtran.cls
Document Class: IEEEtran 2015/08/26 V1.8b by Michael Shell
-- See the "IEEEtran_HOWTO" manual for usage information.
-- http://www.michaelshell.org/tex/ieeetran/
(C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/latex/psnfss\ot1ptm.fd)
-- Using 8.5in x 11in (letter) paper.
-- Using PDF output.
-- This is a 10 point document.
)
** ATTENTION: Overriding command lockouts (line 2).
(C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/latex/cite\cite.sty)
(C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/latex/amsmath\amsmath.sty
For additional information on amsmath, use the `?' option.
(C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/latex/amsmath\amstext.sty
(C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/latex/amsmath\amsgen.sty))
(C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/latex/amsmath\amsbsy.sty)
(C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/latex/amsmath\amsopn.sty))
(C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/latex/amsfonts\amssymb.sty
(C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/latex/amsfonts\amsfonts.sty))

(C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/latex/algorithms\algorithmic.
sty (C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/latex/base\ifthen.sty)
(C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/latex/graphics\keyval.sty))
(C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/latex/graphics\graphicx.sty
(C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/latex/graphics\graphics.sty
(C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/latex/graphics\trig.sty)
(C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/latex/graphics-cfg\graphics.c
fg)
(C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/latex/graphics-def\pdftex.def
))) (C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/latex/base\textcomp.sty)
(C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/latex/xcolor\xcolor.sty
(C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/latex/graphics-cfg\color.cfg)
) (C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/latex/base\fontenc.sty
(C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/latex/cyrillic\t2aenc.def
(C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/latex/base\t2aenc.dfu))
(C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/latex/psnfss\t1ptm.fd))
(C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/latex/l3backend\l3backend-pdf
tex.def)
No file test.aux.
(C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/latex/cyrillic\t2acmr.fd)
-- Lines per column: 56 (exact).

(C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/context/base/mkii\supp-pdf.mk
ii
[Loading MPS to PDF converter (version 2006.09.02).]
)
(C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/latex/epstopdf-pkg\epstopdf-b
ase.sty
(C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/generic/infwarerr\infwarerr.s
ty) (C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/latex/grfext\grfext.sty
(C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/generic/kvdefinekeys\kvdefine
keys.sty))
(C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/latex/kvoptions\kvoptions.sty
(C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/generic/ltxcmds\ltxcmds.sty)
(C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/generic/kvsetkeys\kvsetkeys.s
ty))
(C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/generic/pdftexcmds\pdftexcmds
.sty (C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/generic/iftex\iftex.sty)
)) (C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/latex/amsfonts\umsa.fd)
(C:\Users\mcmun\AppData\Local\Programs\MiKTeX\tex/latex/amsfonts\umsb.fd)

! LaTeX Error: Command \cyrd unavailable in encoding T1.

See the LaTeX manual or LaTeX Companion for explanation.
Type  H <return>  for immediate help.
 ...                                              
                                                  
l.61 This and the IEд
                      фа фуадсфх ахфхсэайо хфойаш о...
6
  • 2
    (1) welcome, (2) please reduce your example to something small that shows the problem. You're adding a lof of irrelevant test here. – daleif Sep 25 '20 at 11:26
  • 1
    Welcome to the site! Could you please copy-paste a minimal example in a code block, instead of giving us a partial screenshot? That would make it much easier to reproduce the problem and help you. – Davislor Sep 25 '20 at 15:38
  • Depending on what fonts the class file selects, you might need to: load babel, \usepackage[T2A,T1]{fontenc}, or declare a substitutefont for Cyrillic. – Davislor Sep 25 '20 at 15:40
  • Are you sure you want to use a Russian title for a document in English? Or is the whole paper in Russian? – egreg Sep 27 '20 at 9:18
  • Thanks for editing your question, but could you please give us a minimal working example inside a code block? A partial screenshot isn’t nearly as helpful. – Davislor Sep 27 '20 at 15:20
0

From your comments, it sounds as if you want to use Mongolian with a document class that sets the font to Times. (The more information you give us about what you are trying to do, the easier it is to help.) Since the default Times font does not support Cyrillic, you must select a supplementary font that does, such as Tempora. Here is a template in Mongolian.

\documentclass{article}
\usepackage[paperwidth=10cm]{geometry} % Format MWE for TeX.SX
\tracinglostchars=2 % Warn if a font does not contain a character
\usepackage{tgtermes} % Times clone.
\usepackage[T1,T2A]{fontenc} % Select a Cyrillic encoding
\usepackage[utf8]{inputenc} % The default since 2018
\usepackage[english, main=mongolian]{babel}
\usepackage{substitutefont} % For \substitutefont
\babeltags{mongolian=mongolian} % Enable \textmongolian, \begin{mongolian}, etc.
\babeltags{english=english}
\usepackage{microtype} % Enable font expansion and protrusion.
\substitutefont{T2A}{\rmdefault}{Tempora-TLF} % Supplementary font for Cyrillic

\begin{document}
\section*{ХҮНИЙ ЭРХИЙН ТҮГЭЭМЭЛ ТУНХАГЛАЛ}

Хүн төрөлхтөний гэр бүлийн бүх гишүүнд угаас заяасан нэр төр болон тэдний тэгш, салшгүй эрхийг хүлээн зөвшөөрөх нь эрх чөлөө, шударга ёс, бүх нийтийн энх тайвны үндэс мөнийг иш үндэс болгон,

хүний эрхийг үл тоомсорлох, басамжлах нь зон олны жигшлийг төрүүлсэн балмад үлйдэлд хүргэж байсан бөгөөд хүмүүс үг хэл, итгэл үнэмшилтэй байх, эрх ёөлөөтэй, айх аюулгүй, гачигдал зовлонгүй дэлхий ертөнцийг бий болгох нь хүн ардын эрхэм дээд эрмэлзлэл мөн хэмээн үзэж,
\end{document}

Tempora sample

The text should be an excerpt from the UN Declaration of Human Rights.

Original Answer

Your latest edit includes the console messages, which give us enough information to diagnose the problem. (For future reference, it would be much better to copy-and-paste enough source code to reproduce the bug, as text in a code block, not a partial screenshot. We can then copy and edit it.)

You’re loading the T2A encoding, but not ever selecting it. You also aren’t loadling a Cyrillic font.

Insert the following lines into your preamble, tweaking as appropriate.

\tracinglostchars=2
\usepackage[english, main=russian]{babel}
\usepackage{substitutefont}
\babeltags{russian=russian}
\babeltage{english=english}
\substitutefont{T2A}{\rmdefault}{Tempora-TLF}

This will select Tempora as the companion font for Times whenever you change the language to Russian. (Or replace russian with the correct language.) It will also print a warning message whenever you try to use a character that the current font does not contain, rather than silently printing it to the log.

To change languages, write all English phrases as \textenglish{ABCD} and all English paragraphs between \begin{english} and \end{english}. Or set English as the main lanugage, and write all Russian phrases as \textrussian{АБВГД} with all Russian paragraphs between \begin{russian} and \end{russian}.

8
  • Thank you very much it has helped my day – SoulNoobster Sep 28 '20 at 4:48
  • hmm when i want to use cyrillic on \section{АБВГД} it is giving me 'error No declaration for shape T2A/Tempora-TLF/m/sc. \section{Induction} ' the main language is the Cyrillic i dont really need to do \textenglish on english for some reason it works fine – SoulNoobster Sep 29 '20 at 9:40
  • @SoulNoobster You’re trying to set small caps, which that font doesn’t have. – Davislor Sep 29 '20 at 9:45
  • @SoulNoobster If you can’t switch to fontspec and compile in LuaLaTeX or XeLaTeX, a workaround would be to replace Tempora-TLF with OldStandard-TLF, which does have small caps and slanted small caps. – Davislor Sep 29 '20 at 9:51
  • Thanks for help but i came across another problem im very sorry wasting your time. The problem is {Ө} {ө} {Ү} {ү} from Mongolian alphabet it doesnt have any compiling error at all but it wont show on pdf file it just ignores {Ө} {ө} {Ү} {ү} it wont show its like this {Хүү} compile {Х} only the x show EDIT: hmm Tempora-TLF works fine {Ө} {ө} {Ү} {ү} shows fine but OldStandard-TLF doesnt show {Ө} {ө} {Ү} {ү} – SoulNoobster Oct 9 '20 at 9:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.