Command \Bbbk' already defined. ...ol{\Bbbk} {\mathord}{AMSb}{"7C} when I try to run the mnras_template.tex

It worked at first and then is updated some of the packages and now it will not run without commenting out some of the packages.

  • 2
    Welcome to TeX.SE.. Can you provide a MWE of your code, i.e., from \documentclass to \end{document} in a workable format...
    – MadyYuvi
    Commented Sep 28, 2020 at 5:11
  • 1
    you have answered your own question: you have two packages defining this command, the easiest way to find them (and fix the problem) is removing or commenting out one of the packages. It appears you have done that already and without seeing the code no one can really help further. Commented Sep 28, 2020 at 7:25
  • I am trying to format a paper for the Royal Astronomical Society. They direct me to a template mnras_template.tex that may be found on ctan.org/tex-archive/macros/latex/contrib/mnras. Commented Sep 28, 2020 at 15:05
  • The full code for mnras_template.tex is too large to put in this window. Can I `Stop' a copy of Bbbk before the error is generated? Commented Sep 28, 2020 at 15:15
  • Since I work with the MNRAS template too, I tried to include the MWE here but it was declined by 2/3 editors, who knows why tex.stackexchange.com/review/suggested-edits/202209 For MWE, see my answer below, then. Commented Nov 30, 2020 at 17:10

3 Answers 3


The issue is in their template file (the MWE is below because when I tried to include the MWE in the question, my edit was rejected).

My solution:

Comment out or better delete the line saying \usepackage{amssymb} because it clashed with the updated version of the MNRAS package.

Solution proposed by the MNRAS publishers:

Move the line


to the end of the preamble. This works with or without loading amssymb separately. Hopefully, a new version of the template on CTAN will reflect this change as well.



% MNRAS is set in Times font. If you don't have this installed (most LaTeX
% installations will be fine) or prefer the old Computer Modern fonts, comment
% out the following line
% Depending on your LaTeX fonts installation, you might get better results with one of these:
% \usepackage{mathptmx}
% \usepackage{txfonts}

% Use vector fonts, so it zooms properly in on-screen viewing software
% Don't change these lines unless you know what you are doing
% \usepackage[utf8]{inputenc}

% Allow "Thomas van Noord" and "Simon de Laguarde" and alike to be sorted by "N" and "L" etc. in the bibliography.
% Write the name in the bibliography as "\VAN{Noord}{Van}{van} Noord, Thomas"


% Only include extra packages if you really need them. Common packages are:
\usepackage{graphicx}   % Including figure files
\usepackage{amsmath}    % Advanced maths commands
\usepackage{amssymb}    % Extra maths symbols  <----- DELETE THIS LINE

\title[Short title, max. 45 characters]{MNRAS \LaTeXe\ template -- title goes here}

\author[authors running]{
First Author$^{1}$\thanks{E-mail: email}
% List of institutions

% These dates will be filled out by the publisher
\date{Accepted XXX. Received YYY; in original form ZZZ}

% Enter the current year, for the copyright statements etc.

% Don't change these lines


keyword1 -- keyword2 -- keyword3



\bibliography{example} % if your bibtex file is called example.bib

% Don't change these lines
\bsp    % typesetting comment
  • Both solutions work but some symbols (e.g. \ltimes) have changed appearance w.r.t. what they looked like before the error first occurred.
    – dremodaris
    Commented Feb 16, 2021 at 14:38
  • I'm trying to understand exactly what happened here. MNRAS changed the formatting or something in these few months at the end of 2020?
    – Swike
    Commented Mar 3, 2021 at 22:43
  • MNRAS changed a lot of things lately, and dealing with their current publishing office was by far the worst experience I had among the journals ever Commented Jun 3, 2021 at 15:20

As both newtxmath and amssymb pkgs define \Bbbk, you simply need to add \let\Bbbk\relax in between them to disable the preceding definition. Say you want to keep the definition in newtxmath, then the following should do.


It not work. Hereis mine:

In mymain.tex


In ccnuthesis.cls


In ccnuthesis.sty

 \ProvidesPackage{ccnuthesis}[2017/12/28 4.1 put any packages you would like to use here]
  1. I've move \usepackage{ccnuthesis} after \usepackage{amssymb}. Error appear!
  2. I've add %%\let\Bbbk\relax in the front ling of \usepackage{amssymb}. Error appear!
  • As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Commented Jun 1, 2022 at 12:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .