4

I've seen the previous threads on this error such as this thread and this and carried out the instructions here.

So that being said, I've installed l3backend through MikTex Console and I still receive this error. Here's a screenshot of my MikTeX console. Screenshot of MikTex Console

I'm getting the error on the simplest possible examples. Here is what the setup wizard puts out -- it gives me an error.

\documentclass[12pt,a4paper]{report}
\usepackage[utf8]{inputenc}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{amssymb}
\begin{document}
This... is a test...
\end{document}

Screenshot of TexMaker follows. I've reinstalled MikTex, reinstalled the l3backend package and restarted my computer numerous times. Not sure what to do next. Any help is appreciated. Thanks.

enter image description here

4
  • Looks ok, and on my miktex it works. Try to rebuild the filename database (menu task, both in user mode and admin mode, if you have a multiuser installation) Sep 29, 2020 at 6:09
  • 1
    I had a similar issue and I resolved it by updating all relevant packages (l3backend, l3kernel, termmenu) Oct 8, 2020 at 7:39
  • I still have the same problem and I have tried ALL the above but haven't been able to fix it. Please help!!
    – Kasra
    Jan 26, 2021 at 4:46
  • 1
    The OP probably didn't have this problem, but I did: the MiKTeX Console won't warn you if expl3 is installed by the Admin account on your computer, but it won't update it when you click Update unless you set it to Administrator mode. Also, the the "Packaged on" date is not the date of the installed version, it's just the date of the version available online.
    – user7868
    Dec 9, 2021 at 5:56

1 Answer 1

0

This answer is not going to solve the problem with MiKTeX but I found a way to get around it and I'm putting this out there for someone who is on the same boat as I was. I scraped the internet to solve the problem with MiKTeX and found NO solution that worked for me. I ended up giving up on MikTeX (possibly forever), uninstalled it completely and had a fresh install of TeX Live. My TeX stuff work like a charm now... just saying!

1
  • Interesting. But I think that the original problem was caused by multiple installations, using different accounts, as was mentioned in comments above. I have seen this kind of problem asked by other users here, from time to time. The catch is that on Windows (and maybe others), uninstallation may leave behind settings, and those settings may point to wrong places. Requires manual cleanup. The fresh TeXlive presumably disregarded any prior MiKTeX stuff.
    – user287367
    Feb 12 at 17:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .