I tried to compile this example but the LaTeX compiler gives the following errors. What can I do?

name = tngani, rootname = tngani, pointsize = mktexmf: empty or non-existent rootfile!

Cannot find font tngani in map file(s).

kpathsea: Running mktexmf tngani.mf The command name is 
C:\texlive\2011\bin\win32\mktexmf Cannot find tngani.mf .
I try ps2pk --> gsftopk --> ttf2pk --> hbf2gf. ps2pk cannot be used.
I try gsftopk. gsftopk.exe tngani 1650 gsftopk cannot be used.
Next I try ttf2pk. ttf2pk.exe -q tngani 1650 ttf2pk failed.
Finally I try hbf2gf. hbf2gf.exe -q -p tngani 1650
All trials failed.
kpathsea: Running mktexpk --mfmode / --bdpi 600 --mag 2+450/600 --dpi 1650 tngani
The command name is C:\texlive\2011\bin\win32\mktexpk 
kpathsea: Appending font creation commands to missfont.log.

Process exited with error(s)

Here is the code:




enter image description here

1 Answer 1


The tengwarscript package provides only the metric files for the fonts, but not the fonts themselves which must be downloaded from the sites shown in the documentation.

You can, for instance, download the "Annatar" fonts from here and unpack the ZIP file; then move the .ttf files in


which should be


for a Unix system (create the necessary directories). Then a run of mktexlsr will make the font available. Add the declaration


just after the \documentclass line and the document should compile.

For other font families, look around on the net, for instance here. Unfortunately, a link where several font families were available for download has disappeared.

  • I downloaded the font that you linked, and I put the ttf file here C:\texlive\texmf-local\fonts\truetype\Annatar I have created this directory: "truetype\Annatar" because did not exist. I use windows 8, I tried to compile the code I added in question but always the same error
    – Aurelius
    May 19, 2012 at 22:40
  • @FormlessCloud Did you run mktexlsr? This should be done as Administrator, if you installed TeX Live in that way. I believe it can be done from tlmgr.
    – egreg
    May 19, 2012 at 22:42
  • i have found mktexlsr.exe here C:\texlive\2011\bin\win32 i have run it as administrator but say error
    – Aurelius
    May 19, 2012 at 23:52
  • I also want to ask you how i can translate in Italian the writing that I put in the question as imagine
    – Aurelius
    May 19, 2012 at 23:59
  • "i have found mktexlsr.exe here C:\texlive\2011\bin\win32 i have run it as administrator but latex say the same error"
    – Aurelius
    May 20, 2012 at 0:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .