5

I want to use LaTeX notes in Xournal++ on Ubuntu to annotate on .pdf. However when I click on insert a LaTeX formula, I got:

Could not find LaTeX package 'standalone'. Please install standalone (found in texlive-latex-extra) and make sure it's accessible by your LaTeX installation).

enter image description here

I went online to search for help and tried:

sudo apt-get install texlive-latex-extra

which gave:

texlive-latex-extra is already the newest version (2019.202000218-1). 0 upgraded, 0 newly installed, 0 to remove and 211 not upgraded.

I tried a tlmgr install with:

$ tlmgr install standalone (running on Debian, switching to user mode!)

/usr/bin/tlmgr: unexpected return value from verify_checksum: -5

I finally went here because of the unexpected return value:

tlmgr --verify-repo=none install standalone (running on Debian, switching to user mode!)

tlmgr: Local TeX Live (2019) is older than remote repository (2020). Cross release updates are only supported with
update-tlmgr-latest(.sh/.exe) --update See https://tug.org/texlive/upgrade.html for details.

Are there other steps I am missing or am I doing it completely wrongly?

9
  • If you are using LaTeX from Ubuntu you cannot use tlmgr to install latex packages, Ubuntu wants you to get LaTeX packages via Ubuntu bundles. Are you sure you don't by an strange reason have more than one LaTeX installation? Such that Xournal++ (which I've never heard of) sees the wrong latex. For example in a terminal what does kpsewhich standalone.sty give?
    – daleif
    Oct 1, 2020 at 12:14
  • @daleif, thanks for your comment. Didn't know for tlmgr. Here's the output $ kpsewhich standalone.sty /usr/share/texlive/texmf-dist/tex/latex/standalone/standalone.sty Does it mean I have one LaTeX installation?
    – JKHA
    Oct 1, 2020 at 12:16
  • That means that when you use the terminal then the standalone package is available. Are there any logs from Xournal++ where one can see what it is doing? And what happens if you start it via the terminal instead of via, say, a menu or double clicking.
    – daleif
    Oct 1, 2020 at 12:23
  • @daleif, I didn't find any logs. Maybe because it's a GUI app. I found how to launch the GUI from terminal. When I then clicked on LaTeX Formulas I got : kpsewhich: /etc/texmf/web2c/texmf.cnf: Permission denied From there, I told myself, maybe it needed sudo xournalpp but this command says : kpsewhich: /etc/texmf/web2c/texmf.cnf: Permission denied . Sorry we are walking a little away from TeX!
    – JKHA
    Oct 1, 2020 at 12:36
  • That sounds more like you have a very strange setup. Sorry cannot help you more.
    – daleif
    Oct 1, 2020 at 12:42

1 Answer 1

6

Alright, it is not exactly a fixing way but at least it worked. I uninstalled Xournal++ with Ubuntu software.

I then reinstalled it with:

sudo add-apt-repository ppa:apandada1/xournalpp-stable
sudo apt update
sudo apt install xournalpp

As suggested in the GitHub Readme. And now the LaTeX Formulas work. The version of xournalpp in Ubuntu's software center is a sandboxed snap package, and it has incompatibility issues with external components like LaTeX. Installing the native Debian package (in the PPA) solves the problem.

I also now understand it's not that much a LaTeX related question.

2
  • Which Ubuntu are you using? I did not find it in my Ubuntu 18.04 and thus used the same approach
    – daleif
    Oct 1, 2020 at 15:33
  • @daleif, I'm using Ubuntu 20.04
    – JKHA
    Oct 1, 2020 at 16:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.