0

I'm having trouble getting citations to work, apparently because of errors when I try to compile the bibliography. When I compile and build the PDF, the footnotes appear but they just appear as the tags in the underlying .bib file:

enter image description here

When I use the bibliography command Tools>>Bibliography, I'm returned the following error message

Process started: bibtex "MyFile".aux

This is BibTeX, Version 0.99d (TeX Live 2017) The top-level auxiliary file: MyFile.aux I found no \citation commands---while reading file MyFile.aux I found no \bibdata command---while reading file MyFile.aux I found no \bibstyle command---while reading file MyFile.aux (There were 3 error messages)

Process exited with error(s)

Any thoughts on how to fix this?

4
  • you are using biblatex? Then you need to use biber and not bibtex. Oct 1, 2020 at 18:34
  • I was using bibtex. But I just switched the TexStudio preferences to biber and still have the same problem. Here's the output: INFO - This is Biber 2.7 INFO - Logfile is 'MyFile.blg' INFO - Reading 'MyFile.bcf' INFO - Found 92 citekeys in bib section 0 INFO - Processing section 0 INFO - Looking for bibtex format file 'DKIS.bib' for section 0 INFO - Decoding LaTeX character macros into UTF-8 INFO - Found BibTeX data source 'DKIS.bib'
    – dl09
    Oct 1, 2020 at 19:10
  • WARN - BibTeX subsystem: /var/folders/s6/bxlsj_jj5bl48q6y42p5fvl80000gp/T/DHKLDKsv4A/DKIS.bib_41712.utf8, line 1820, warning: 30 characters of junk seen at toplevel WARN - I didn't find a database entry for 'MitchellPrins2004' (section 0) INFO - Overriding locale 'en-US' defaults 'variable = shifted' with 'variable = non-ignorable' INFO - Overriding locale 'en-US' defaults 'normalization = NFD' with 'normalization = prenormalized' INFO - Overriding locale 'en-US' defaults 'level = 4' with 'level = 2'
    – dl09
    Oct 1, 2020 at 19:12
  • INFO - Sorting list 'cms/global/' of type 'entry' with scheme 'cms' and locale 'en-US' INFO - No sort tailoring available for locale 'en-US' INFO - Writing 'MyFile.bbl' with encoding 'UTF-8' INFO - Output to MyFile.bbl INFO - WARNINGS: 2 Process exited normally
    – dl09
    Oct 1, 2020 at 19:12

1 Answer 1

0
  • use \usepackage{biblatex}
  • Make biber default bibtex compiler in your editor
  • load bibliography information in a separate file, say ref.bib
  • add your bibliography resource in the preamble \bibliography{ref.bib}
  • put \printbibliography where you want it printed
  • Make sure your compilation is as follows:

default compiler -> biber -> default compiler -> default compiler -> view pdf

Note the double compilation. Default compiler can be pdflatex or xelatex, your choice. You should be able to edit your default compiler in your editor. Best editor in my opinion is TexStudio. You can add the series of commands there.

4
  • Thank you! I use TexStudio but am relatively new. Where should I put in the compilation instructions (default compiler -> biber -> default compiler -> default compiler -> view pdf)?
    – dl09
    Oct 1, 2020 at 19:07
  • Options -> configure TexStudio. see here. imgur.com/JDxivee
    – Masum
    Oct 1, 2020 at 19:17
  • Thank you! It's working now. Much appreciated.
    – dl09
    Oct 1, 2020 at 19:46
  • then you can accept this as answer and close the question as answered
    – Masum
    Oct 1, 2020 at 19:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.