6

I'm using amsmath and the standard math packages, nothing fancy. This is my expression:

\begin{equation*}
e^{i \int \!dt\,\frac{1}{2}m\dot x^2}
\end{equation*}

I am unhappy with how small the integral sign is:

enter image description here

When I write

\begin{equation*}
e^{i \big\int \!dt\,\frac{1}{2}m\dot x^2}
\end{equation*}

it looks exactly correct:

enter image description here

However, when I use \big I get a compiler warning and I can't live with it. I need it to compile without any warnings. The error is:

Missing delimiter (. inserted). ...ta t}\right)^{\!\frac{N}{2}}e^{i \big\int

I tried all combinations of spaces and \big{\int}, etc but I can't get the compiler warning to go away. How can I make my integral a little bit bigger in the exponent without getting the error? THANKS!!!

4
  • Welcome to TeX.SX. When you post a question, please provide a "Minimal Working Example" (MWE) that starts with \documentclass, includes all relevant \usepackage commands, ends with \end{document} and compiles without errors, even if it does not produce your desired output. – Sandy G Oct 2 '20 at 2:51
  • Actually, I'd prefer an integral in between those sizes, just the size of the 1/2 fraction. – Donald Arseneau Oct 2 '20 at 5:07
  • 4
    I'm not sure you really want a bigger integral sign that will make it difficult to spot that the whole thing is an exponent. Why not \exp\bigl(\int dt\,\frac{1}{2}m\dot{x}^2\bigr)? – egreg Oct 2 '20 at 8:28
  • 5
    Does this answer your question? Big integral sign – user108724 Oct 2 '20 at 15:05
9

You can use \textstyle.

enter image description here

\documentclass{article}

\usepackage{mathtools}

\begin{document}

\begin{equation*}
e^{i{\textstyle\int} dt\,\frac{1}{2}m\dot x^2}
\end{equation*}

\end{document}
7

I agree that the integral is small in the superscript, but I think the \textstyle option is too large. For a happy medium I modified the declaration found in exscale.sty to give this

\DeclareFontShape{OMX}{cmex}{m}{n}{%
      <-7>sfixed * cmex7
      <7-8>sfixed * cmex8
      <9>  cmex9
      <10> <10.95> <12> <14.4> <17.28> <20.74> <24.88>cmex10
       }{}

Comparing the two versions of output (including an integral in scriptscriptstyle)

Amsmath sizes:

AMSmath integral sizes

\DeclareFontShape sizes:

my declaration integral sizes

This is specific to computer modern math fonts (because "cmex"), but also affects other parts of math taken from the math extension font. One notable effect is the default rule thickness (fontdimen 8 from the extension font). The effect can be seen on the fractions.

4

A couple things are going on here. First \big can only be used on delimiters, not on operators which is the source of your error.

Second, the smaller integral sign is a result of loading the amsmath package. Without it, you get the integral sign as shown in your second example. I'm not entirely sure whether the amsmath or the default behavior is the defective one. You'll need to do something like the following to get the correct spacing and sizing of the integral:

e^{ i\mathop {\textstyle\int} \!dt\,\frac{1}{2}m\dot x^2}

enter image description here

I am curious about what's going on below the hood to make \int behave differently and this does merit further investigation.

Edit: Ignore the "solution" above. If you want the default behavior, the way to do this is to specify the cmex10 option when loading amsmath:

\usepackage[cmex10]{amsmath}
1
  • 4
    The standard LaTeX way is awful -- using cmex10 no matter what requested font size (documentclass size, size changes, and math style are ignored). If not amsmath, use package exscale or fixcmex. – Donald Arseneau Oct 2 '20 at 4:30

Not the answer you're looking for? Browse other questions tagged or ask your own question.