0

Compiling the following MWE:

\documentclass{article}

\usepackage[
    type={CC},
    modifier={by-sa},
    version={4.0},
    lang={spanish}
]{doclicense}

\usepackage{lipsum,siunitx}

\begin{document}
    
\lipsum[1-3]
    
\end{document}

When I compile I get the follwing error:

! Undefined control sequence.
<argument> \hyxmp@dc@lang 

However, even with the error, a PDF is produced. How does one get rid of the error? This started happening after my last TeXLive upgrade; current version is 2020.20200925-1 (running on Debian Testing); doclicense is version 2.2.1.dev.

0

The doclicence package says that it requires hyperxmp. However, your code would not run for me unless I explicitly loaded hyperxmp under v2.2.0 of doclicense. When I updated to v2.2.1 of doclicense the issue went away. (I have v5.4 of hyperxmp.)

\documentclass{article}

\usepackage[
    type={CC},
    modifier={by-sa},
    version={4.0},
    lang={spanish}
]{doclicense}

\usepackage{lipsum,siunitx,hyperxmp} % <--- load hyperxmp with v2.2.0 of doclicense

\begin{document}
    
\lipsum[1-3]
    
\end{document}

By loading hyperxmp explicitly, I got the output shown below with v2.2.0 of doclicense: enter image description here

1
  • Right! I suppose the version I have of doclicense is still "in development", because it says it is v.2.2.1.dev. This works; what I don't understand is why now, I had been working with files using doclicense before without this error. Thanks! – mathbekunkus Oct 7 '20 at 3:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.