0

The org document below generates a tex file that compiles as follows:

*** 理性與情感的對立

**** Yang, X. (2006). A Moral Psychology without the Concept of Reason? History of Philosophy Quarterly, 23(4), 295–318.
:PROPERTIES:
:UNNUMBERED: t
:END:

Lorem ipsum dolor sit amet, consectetur adipiscing elit. Vivamus at vestibulum libero. Morbi mattis elit nunc, eu molestie neque dignissim ac. Praesent commodo neque volutpat ligula gravida, a placerat nunc fermentum. Curabitur pellentesque mollis nisi id aliquet. Integer pellentesque nulla a maximus dapibus. In non nisi turpis. Mauris condimentum hendrerit velit, vel ultrices purus commodo vel.

TeX snippet:

\subsubsection{理性與情感的對立}
\label{sec:orgd4added}

\begin{itemize}
\item Yang, X. (2006). A Moral Psychology without the Concept of Reason? History of Philosophy Quarterly, 23(4), 295–318.
\label{sec:org7a3494f}

Lorem ipsum dolor sit amet, consectetur adipiscing elit. Vivamus at vestibulum libero. Morbi mattis elit nunc, eu molestie neque dignissim ac. Praesent commodo neque volutpat ligula gravida, a placerat nunc fermentum. Curabitur pellentesque mollis nisi id aliquet. Integer pellentesque nulla a maximus dapibus. In non nisi turpis. Mauris condimentum hendrerit velit, vel ultrices purus commodo vel.\\
\end{itemize}

Output:

no new line between heading and text

How do I automatically force a new line between the bibliographic item and the text that follows so that they can be better separated?

Removing the unnumbered property in the org source file results in a more presentable outlook. So another way to put the question would be: How to make itemize behave like enumerate?

TeX snippet:

\subsubsection{理性與情感的對立}
\label{sec:org864049f}

\begin{enumerate}
\item Yang, X. (2006). A Moral Psychology without the Concept of Reason? History of Philosophy Quarterly, 23(4), 295–318.
\label{sec:orgc05f912}

Lorem ipsum dolor sit amet, consectetur adipiscing elit. Vivamus at vestibulum libero. Morbi mattis elit nunc, eu molestie neque dignissim ac. Praesent commodo neque volutpat ligula gravida, a placerat nunc fermentum. Curabitur pellentesque mollis nisi id aliquet. Integer pellentesque nulla a maximus dapibus. In non nisi turpis. Mauris condimentum hendrerit velit, vel ultrices purus commodo vel.\\
\end{enumerate}

Output:

more presentable result


I am including the entire code to the snippet above so that we may find out what made itemize behave differently.

The Entire Code:

% Created 2020-10-08 Thu 17:06
% Intended LaTeX compiler: pdflatex

\documentclass[12pt,a4paper]{article}
%\documentclass[12pt,a4paper]{ctexart}

\usepackage{xeCJK}
\usepackage{zhnumber} % package for Chinese formatting of date time (use /zhtoday)
\usepackage[yyyymmdd]{datetime} % set date time to numeric

% For Generation of Citations and Bibliography
\usepackage[notes, isbn=false, backend=biber]{biblatex-chicago}
\bibliography{/Users/satibodhi/Creation/notes/bibliography/thesis}

% Set default indentation

\setlength\parindent{24pt}

% Set Paper Size, Page Layout (another variable is 'bindingoffset')
\usepackage[margin = 1.5in, paper = a4paper, inner = 2.5cm,
outer = 2.5cm, top = 3cm, bottom = 2.5cm]{geometry}

% Keep paragraph indentation while having a line break in between paragraphs.
\edef\restoreparindent{\parindent=\the\parindent\relax}
\usepackage{parskip}
\restoreparindent

% Indent first paragraph.
\usepackage{indentfirst}

\usepackage{titlesec}
\usepackage{titling}
\usepackage{fontspec} % packages for title and section-heading font setting.
\usepackage{newunicodechar} % custom fallback font for certain unicode characters.
\usepackage{tocloft} % adding the tocloft package for toc customization

% Set Header and Numbering Depth
\setcounter{tocdepth}{5}
\setcounter{secnumdepth}{5}

% Set Font.
\setsansfont{Times New Roman}
\setmainfont{Calibri} % Set serifed font to Calibri. Originally set to 'Times New Roman', but it cannot display certain characters such as ①②③.
\setCJKmainfont{Songti TC}
\setCJKsansfont{Kaiti TC} % Set Chinese font. NOTE: Remember to append CJK before of the font class. CJK HAS to be there for the font to show.
\setCJKmonofont{PingFang TC}

% Set fallback fonts for ㊀ characters.

\newCJKfontfamily\fallbackfont{PingFang TC}
\newunicodechar{㊀}{{\fallbackfont ㊀}}
\newunicodechar{㊁}{{\fallbackfont ㊁}}
\newunicodechar{㊂}{{\fallbackfont ㊂}}
\newunicodechar{㊃}{{\fallbackfont ㊃}}
\newunicodechar{㊄}{{\fallbackfont ㊄}}
\newunicodechar{㊅}{{\fallbackfont ㊅}}
\newunicodechar{㊆}{{\fallbackfont ㊆}}
\newunicodechar{㊇}{{\fallbackfont ㊇}}
\newunicodechar{㊈}{{\fallbackfont ㊈}}
\newunicodechar{㊉}{{\fallbackfont ㊉}}

% WHEN \documentclass is set to {article},
% zhnum[style={Traditional,Financial}] doesn't work with the section counter,
% so we define our own counter and increase it every time in \thesection.

\newcounter{mysec}[section]
\renewcommand\thesection{%
    \addtocounter{mysec}{1}%
    \zhnum[style={Traditional,Financial}]{mysec}、} % 大標題序號:壹、貳、參、…
\renewcommand\thesubsection{\zhnum{subsection}、} % added a 、小標題序號:一、二、三、…
\renewcommand\thesubsubsection{(\zhnum{subsubsection})} % added parentheses
% (full-width, don't know if that's what you want) 副標題序號:(一)(二)(三)
\renewcommand\theparagraph{\arabic{paragraph}} % arabic numbering for paragraph
\renewcommand\thesubparagraph{} % no subparagraph numbering

% we have to adjust the spacing in the toc because the section label is longer than usual
\addtolength\cftsecnumwidth{1em}
\addtolength\cftsubsecindent{1em}
\addtolength\cftsubsubsecindent{1em}

% Set formats for each heading level. 'sffamily' will point to the sans-serif font. In this case, 「楷體」.

% here we need to make sure the normal section counter is accessed
\titleformat{\section}{\LARGE\bfseries\sffamily\filcenter}
    {\zhnum[style={Traditional,Financial}]{section}、}{.5em}{}

\titleformat*{\subsection}{\Large\bfseries\sffamily}
\titleformat*{\subsubsection}{\large\bfseries\sffamily} % Set formats for each heading level. 'sffamily' will point to the sans-serif font. In this case, 「楷體」.

% The `titlesec` package is used over here to make use of `\paragraph` and `\subparagraph` as headings. Up to five levels of headings can be implemented this way.

% no extra version for numberless is necessary since no numbers are used anyways
% also you get newlines from omitting the [display] in \titleformat already
\titleformat{\paragraph}[block]
    {\large\bfseries\sffamily}{\theparagraph}{0em}{}
\titleformat{\subparagraph}[block]
    {\large\bfseries\sffamily}{}{0em}{}
% we need the following so that they don't indent (second argument, 0em);
% you'll have to adjust the spacing though since this is not display style anymore:
\titlespacing*{\paragraph}{0em}{3.25ex plus 1ex minus .2ex}{.75ex plus .1ex}
\titlespacing*{\subparagraph}{0em}{3.25ex plus 1ex minus .2ex}{.75ex plus .1ex}

% Set title font.
\renewcommand{\maketitlehooka}{\sffamily}

% Set quotation font.
\usepackage{etoolbox}
\newCJKfontfamily\quotefont{Kaiti TC}
\AtBeginEnvironment{quote}{\quotefont\normalsize}

% Tweak default settings.
\renewcommand{\baselinestretch}{1.2} % Set line width.
\renewcommand{\contentsname}{\hfill\bfseries\Large 目\hspace{0.5cm} 錄\hfill} % Translate content page title to Chinese.
\renewcommand{\cftaftertoctitle}{\hfill} % Center contents title.
\renewcommand{\abstractname}{摘要} % Translate abstract title to Chinese.
\renewcommand{\tablename}{表} % Translate table to Chinese.
\renewcommand{\figurename}{圖} % Translate figure to Chinese.

% For text-boxes

\usepackage{mdframed}
\BeforeBeginEnvironment{minted}{\begin{mdframed}}
\AfterEndEnvironment{minted}{\end{mdframed}}

% For tables

\usepackage{float}
\restylefloat{table}

% [FIXME] ox-latex 的設計不良導致 hypersetup 必須在這裡插入
\usepackage{hyperref}
\hypersetup{
  colorlinks=true, %把紅框框移掉改用字體顏色不同來顯示連結
  linkcolor=[rgb]{0,0.37,0.53},
  citecolor=[rgb]{0,0.47,0.68},
  filecolor=[rgb]{0,0.37,0.53},
  urlcolor=[rgb]{0,0.37,0.53},
  pagebackref=true,
  linktoc=all,}

\usepackage{hyperref}
\usepackage{graphicx}
\usepackage{longtable}
\usepackage{wrapfig}
\usepackage{rotating}
\usepackage[normalem]{ulem}
\usepackage{amsmath}
\usepackage{textcomp}
\author{me}
\date{\today}
\title{Annotated Bibliography}
\begin{document}

\maketitle
\tableofcontents \clearpage

\subsubsection{理性與情感的對立}
\label{sec:org3289944}

\begin{itemize}
\item Yang, X. (2006). A Moral Psychology without the Concept of Reason? History of Philosophy Quarterly, 23(4), 295–318.
\label{sec:org686092f}
Lorem ipsum dolor sit amet, consectetur adipiscing elit. Vivamus at vestibulum libero. Morbi mattis elit nunc, eu molestie neque dignissim ac. Praesent commodo neque volutpat ligula gravida, a placerat nunc fermentum. Curabitur pellentesque mollis nisi id aliquet. Integer pellentesque nulla a maximus dapibus. In non nisi turpis. Mauris condimentum hendrerit velit, vel ultrices purus commodo vel.\\
\end{itemize}
\end{document}
7
  • by default an empty line should force a new paragraph also in itemize. So the question is not how to make itemize behave like enumerate but how you managed to get itemize working differently. Oct 8 '20 at 9:16
  • How do I find out?
    – Sati
    Oct 8 '20 at 9:22
  • 2
    create a test document with your preamble and your snippet. Check if it shows the faulty behaviour. Replace the chinese by english in the text, then comment in the preamble everything with exception of the class and check again. If the output is then ok, start to add lines from the preamble until you find the culprit. Oct 8 '20 at 9:37
  • 1
    You just added the snippet, and there is no empty line after the label. Then is quite normal that you don't get a paragraph break. Oct 8 '20 at 9:46
  • 1
    It seems to me that this is an org-export issue. Somehow, org-mode exports to enumerate with an empty line but leaves that out when exporting to itemize. Adding an empty line after the label fixes the problem.
    – Sati
    Oct 8 '20 at 10:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.