2

I am new to latex and trying to make the document. I am using the biblatex to create Bibliography chapter. I am able to get the bibliography list but for some reason the displayed url comes with spaces in Bibliography due to which the URL do not act as the hyperlink. Although when URLs are short such as https://google.com then it works correctly as the URL is displayed in single line but when the URL spans multiple lines then they do not work.

Also I am facing one more issue when I click on the [1 p.1] in the cited section it does not take me to the bibliography section for some reason. Can someone please help me know to resolve the issue. I tried searching but could not find the resolution hence posting the same.

My bibliography example:

@misc{1,
    AUTHOR      =   "John Mortimer Logsdon",
    TITLE       =   "Why space science and exploration benefit everyone",
    MONTH       =   "August",
    YEAR        =   "1998",
    url         =   "https://www.researchgate.net/publication/222505708_Why_space_science_and_exploration_benefit_everyone",
    urldate     =   "2020-08-25",
},

I have used the packages \usepackage{hyperref} and \usepackage[hyphens]{url} and \usepackage{url} but still no luck.

Following is my code, I am just posting the sample code as I am using the template provided my advisor for making the document.

\documentclass[a4paper,
               final,
               draft,
%               oneside,    % einseitiges Layout für kleinere Arbeiten
               12pt]{book}
\usepackage{url}
\usepackage[
  backend=biber,
  style=ieee,
  urldate=long, 
  dateabbrev=false
]{biblatex}
\addbibresource{literatur.bib} 
\usepackage{hyperref}
\usepackage[a-1b]{pdfx}

\begin{document}
It stars with one thing, I don't know why \cite[p.~1]{1}.
\end{document}

The URL looks something like this in Bibliography section: enter image description here

https:/ /www. researchgate.net /publication/ 222505708_ Why_ space_science _and_exploration_benefit_everyone
13
  • 3
    Have you tried turning off the "draft" option? That might disable the links.
    – gmvh
    Oct 9, 2020 at 13:47
  • 1
    I mean in the \documentclass.
    – gmvh
    Oct 9, 2020 at 13:51
  • 1
    @gmvh Thanks a lot man. Removing the draft worked. I was searching from about 1 hour. Tried all sort of things. Thanks again. Oct 9, 2020 at 14:11
  • 3
    If the draft option is turned on, hyperref does not generate any links. If you can click the URL and are sent to some site then that is a heuristic in your PDF viewer and not a hyperref feature. It is not inconceivable that the heuristics don't get this URL right due to the line breaks. If you remove the draft option, hyperref becomes active, does its thing and properly links the URL.
    – moewe
    Oct 9, 2020 at 14:29
  • 1
    Note that in any case it is odd to give both the final and draft option at the same time. In a way final is the opposite of draft. (Though I would use neither in the actual final version of my document unless explicitly required by some odd configuration.)
    – moewe
    Oct 9, 2020 at 14:30

1 Answer 1

4

The problem is with the "draft" option to \documentclass, which disables links in hyperref.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .