3

I would like to add a full-page sized image before the title. However, when using the code below an empty page appears after the image and before the title. If I change the document class to article, the empty page does not occur. How to remove this extra page in book class?

\documentclass{book}
\title{Title}
\usepackage{pdfpages}
\begin{document}
\includepdf[fitpaper=true]{example-image}
\maketitle
\end{document}

1 Answer 1

5

That's because the page numbering for book requires a recto (odd) page for all titles (including those for parts and chapters). article has no such restrictions since it typically doesn't deal with double-sided printing that has recto and verso pages. The easiest way to circumvent that in your situation is to place the image on "page 0" rather than "page 1" by adding \addtocounter{page}{-1} (or setting it verbatim \setcounter{page}{0}).

\documentclass{book}

\title{Title}

\usepackage{pdfpages}

\begin{document}

\addtocounter{page}{-1}% To ensure the title is set on an odd page
\includepdf[fitpaper=true]{example-image}

\maketitle

\end{document}
1
  • 1
    When I tried this, viewing via evince, I got strange output regarding the placement of the image on top of the title. removing the fitpaper=true option to the \includepdf cured that. Commented Oct 12, 2020 at 16:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .