0

After a MiKTeX package update on 26.9.2020 Plain TeX (\input ngerman.sty) is no longer working as it used with my previous version MiKTeX 2.9 of January/February 2019, even after a fresh installation of MiKTeX on 7.10.2020. I cannot get hyphenation and am getting errors with graphics (the fix of Phelype Oleinik of Oct 10'19 seems to work although I am still getting error messages). Can anybody give me a hint?

Example ref. hyphenation:

 \input ngerman.sty
  \hsize=15.9 true cm
  %
  Pforzheim war mit rund $24\,000$ Einwohnern um 1875/1880 nach
  Mannheim, Karlsruhe und Freiburg die viertgr"o"ste  -- zeitweise
  nach dem fast gleichgro"sen Heidelberg die f"unftgr"o"ste -- Stadt Badens
  (Einwohnerzahl 1900: $43\,373$, 1910: $69\,082$, 1925: $78\,859$).
  %
  \bye
 

Should hyphenate but doesn't!

  • Show a complete example that can be used for tests. – Ulrike Fischer Oct 12 at 12:46
  • How did my name pop up here? ;-) Sorry, what fix are you talking about? Can I have a link, please? – Phelype Oleinik Oct 12 at 12:48
1

I can't really believe that something changed here, I get the same behaviour also with older texlive systems. The name of the language commands in ngerman.sty don't fit the names used in plain.

\catcode`\@=11
\expandafter\let\expandafter\l@ngerman\csname lang@ngerman-x-latest\endcsname
\catcode`\@=12
\input ngerman.sty


  \hsize=15.9 true cm
  %
  Pforzheim war mit rund $24\,000$ Einwohnern um 1875/1880 nach
  Mannheim, Karlsruhe und Freiburg die viertgr"o"ste  -- zeitweise
  nach dem fast gleichgro"sen Heidelberg die f"unftgr"o"ste -- Stadt Badens
  (Einwohnerzahl 1900: $43\,373$, 1910: $69\,082$, 1925: $78\,859$).
  %
  \bye

on miktex you probably need to compile with pdfetex instead of pdftex and need another language name:

\catcode`\@=11
\expandafter\let\expandafter\l@ngerman\csname lang@ngerman\endcsname
\catcode`\@=12
\input ngerman.sty


  \hsize=15.9 true cm
  %
  Pforzheim war mit rund $24\,000$ Einwohnern um 1875/1880 nach
  Mannheim, Karlsruhe und Freiburg die viertgr"o"ste  -- zeitweise
  nach dem fast gleichgro"sen Heidelberg die f"unftgr"o"ste -- Stadt Badens
  (Einwohnerzahl 1900: $43\,373$, 1910: $69\,082$, 1925: $78\,859$).
  %
  \bye
| improve this answer | |
  • No help. Thanks anyway! – Schlurch Oct 12 at 20:23
  • check in your miktex settings if the language has a different name (I checked only in texlive). – Ulrike Fischer Oct 12 at 20:31
  • I checked on miktex, there only pdfetex seems to include the hyphenation patterns, and the name is lang@ngerman (at least in my miktex). – Ulrike Fischer Oct 12 at 20:42
  • Thanks, Ulrike! I'm not that experienced with the TeX interna. Moreover, the documentation files don't apply to the present installation. Maybe I should pass – Schlurch Oct 13 at 10:54
  • then why do you use plaintex? That is certainly not something for the non-experienced. – Ulrike Fischer Oct 13 at 10:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.