2

I've noticed BibLaTeX keeps putting linebreaks between authors initials and the last name. I would prefer these to stay together. When I do journal names I can manually specify J.~App.~Cryst. but since the author names are automatically formatted, that isn't something I can do.

Examples drawn from biblatex-examples.bib (Showing it happens with authors, editors, and translators, though in my document authors are the main problem. I would like to keep the text justified if possible.)

\documentclass{article}

\usepackage[style=chem-rsc]{biblatex}
\addbibresource{biblatex-examples.bib}

\begin{document}

How do I get BibLaTeX to stop putting the last name on the next line?\autocite{set,aristotle:physics,cicero}

\printbibliography
\end{document}

Output: Three citations. The first one breaks after the authors initials on both the first and second line. The second breaks after the translators initials. The final one breaks after the editors initial.

4
  • 2
    Bibliographies are difficult in many ways. You say that you don't like journal titles split across lines, and it looks like you have suppressed hyphenation. Adding another restriction like requiring author names to be complete on one line will provide fewer places that lines can break, with the result that spaces may be of wildly different widths, rendering the result very hard to read as well as unsightly. Unless there is an absolute prohibition against it, setting a bibliography ragged right at least allows it to be readable. (But I don't know how to answer the question you asked.) Oct 17 '20 at 3:07
  • There will be an article title between the page numbers and the author names, so I'm not too worried about them interfering with one another, as they never wind up on the same line. That would have to be the shortest article title ever.
    – Canageek
    Oct 17 '20 at 5:30
  • Good luck. Looking at the test by @Guido, you may need to consider adding discretionary hyphens (I know these examples aren't from your own bibliography). And, as a last resort, apply \sloppy to avoid overfull lines. (If anything follows the bibliography, restore \fussy. See tex.stackexchange.com/q/241344 for some discussion that subject.) Oct 17 '20 at 14:40
  • @barbarabeeton After applying it to the first 44 citations in my thesis there is only one error (VERY common one in chemistry where a molecular formula runs over the end of the line, so I know all the tricks to deal with it). So I'm happy about that!
    – Canageek
    Oct 19 '20 at 18:11
4

According to the biblatex manual (Section 3.14.4), the separator used between the given name part and the family name part is \bibnamedelimd. Thus to prevent the line break between the initial and the name, you can set it to \addnbspace (which, generally, is a non-breakable space). Just add

\let\bibnamedelimd\addnbspace

With the provided MWE, it yields.

enter image description here

PS I agree with the comment by Barbara Beeton.

This site is temporarily in read only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .