0

I have used these packages in my springer format, but I am getting above warning. Although warning can be ignored but, without removal of this warning, I am not unable to upload or build pdf on that particular journal website. The warning is about some caption, and I have not used caption sub-package. By adding this package also, I am getting the same error.

Kindly help how me to remove this warning.

My document contains, text, figures, subfigures references only.


\documentclass[twocolumn]{svjour3}          % twocolumn
%
\smartqed  % flush right qed marks, e.g. at end of proof
%

%
% \usepackage{mathptmx}      % use Times fonts if available on your TeX system
%
% insert here the call for the packages your document requires
%\usepackage{latexsym}
% etc.
%
% please place your own definitions here and don't use \def but
% \newcommand{}{}
%
% Insert the name of "your journal" with
% \journalname{myjournal}


\usepackage{cite}
\usepackage{array}
% \usepackage{adjustbox}

\usepackage{tablefootnote}
\usepackage{footnote}
% \usepackage{cleveref}
\usepackage{csquotes}
\usepackage{multirow}
\usepackage{amsmath,amssymb,amsfonts}
\usepackage{diagbox}
\usepackage{ mathrsfs}
\usepackage{bm}
\usepackage{subfig}
\usepackage{algorithmic}
\usepackage{graphicx}
\usepackage{xcolor}
\usepackage{mathtools}
\usepackage[linesnumbered,ruled,vlined]{algorithm2e}
\usepackage{hyperref}
\renewcommand{\arraystretch}{1.2}
\setlength{\tabcolsep}{2.5pt}
\usepackage{textcomp}
\usepackage{caption}% http://ctan.org/pkg/caption

\def\BibTeX{{\rm B\kern-.05em{\sc i\kern-.025em b}\kern-.08em
    T\kern-.1667em\lower.7ex\hbox{E}\kern-.125emX}}
\usepackage{subfig}

\sloppy

7
  • 2
    you are loading the caption package. Remove it. If you want to sent something to a journal which provides a class, avoid to clutter your preamble with lots of packages which perhaps change the layout they want. – Ulrike Fischer Oct 18 '20 at 9:34
  • I have removed it, but still nothing changed – Dipti Mishra Oct 18 '20 at 9:40
  • 1
    then remove more stuff. Or check in the log which package is issuing the warning. – Ulrike Fischer Oct 18 '20 at 9:44
  • 1
    subfig (which you load twice) and subcaption are not compatible. Remove one of it. – Zarko Oct 18 '20 at 10:16
  • I have removed subfig and caption package and now it is working fine. – Dipti Mishra Oct 18 '20 at 10:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.