0

I want that glossaries disappears in the table of content

My code is

\documentclass{scrartcl}
\usepackage[T1]{fontenc}
\usepackage{tgtermes}
\usepackage{siunitx}
\usepackage[hidelinks]{hyperref}
\usepackage[nopostdot=false,
 stylemods=longragged,
 style=longragged3col,
 nogroupskip
]{glossaries-extra}

\setkomafont{disposition}{\normalcolor\bfseries}
\setlength{\glspagelistwidth}{0.12\textwidth}
\makeglossaries
\newglossaryentry{||.||}{name =  {$||.||$},
  description={Norm}}
  
\newcommand*{\glsxtrpostdescforeignenddot}{\space
 (Translation: \glsentryuseri{\glscurrententrylabel})}
\GlsXtrEnablePreLocationTag{}{}

\begin{document}

\tableofcontents

\gls{||.||}

\printglossaries

\end{document} 
3

glossaries-extra has the package option toc=true by default, which adds the glossaries to the table of contents. As the package documentation says:

Use toc=false to switch this back off.

So add toc=false to your \usepackage[...]{glossaries-extra}.

1
  • thank you very much Oct 20 '20 at 5:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.