I am using overleaf.com for the following.

I have recently finished writing my thesis, the document is set up with a main.tex with \input{Chapter01.tex} for each chapter. Up until now I have been compiling only one chapter at a time for convenience, but now I need to compile the full document. Only when I compile the full document with every chapter included, about 30 of my citations fail with the error:

You have cited something which is not included in your bibliography. Make sure that the citation (\cite{...}) has a corresponding key in your bibliography, and that both are spelled the same way.

Not only are these citations definitely included in my .bib file, but if I compile individual chapters, they work. I'll give an example of the first citation which fails below, which I include in the main text as \cite{Broken}

    author = {{De Paolis}, F. and {Giordano}, M. and {Ingrosso}, G. and {Manni}, L. and {Nucita}, A. and {Strafella}, F.},
    title = "{The Scales of Gravitational Lensing}",
    journal = "{Universe}",
    year = 2016,
    month = 03,
    volume = 2, 
    number = 1,

This is the usepackage I'm using:

\usepackage[backend=biber, style=authoryear, maxnames=1, uniquelist=false, uniquename=false]{biblatex}

I tried following what was said in this question Question mark or bold citation key instead of citation number , but It didn't help. My .blg file doesn't seem to have any issues:

[0] Config.pm:354> INFO - This is Biber 2.7

[0] Config.pm:357> INFO - Logfile is 'output.blg'

[41] biber:303> INFO - === Tue Oct 20, 2020, 14:27:28

[76] Biber.pm:359> INFO - Reading 'output.bcf'

[265] Biber.pm:835> INFO - Found 258 citekeys in bib section 0

[291] Biber.pm:3670> INFO - Processing section 0

[308] Biber.pm:3840> INFO - Looking for bibtex format file 'references.bib' for section 0

[399] bibtex.pm:1435> INFO - Decoding LaTeX character macros into UTF-8

[505] bibtex.pm:1292> INFO - Found BibTeX data source 'references.bib'

[2700] UCollate.pm:68> INFO - Overriding locale 'en-US' defaults 'variable = shifted' with 'variable = non-ignorable'

[2701] UCollate.pm:68> INFO - Overriding locale 'en-US' defaults 'normalization = NFD' with 'normalization = prenormalized'

[2701] Biber.pm:3499> INFO - Sorting list 'nyt/global/' of type 'entry' with scheme 'nyt' and locale 'en-US'

[2701] Biber.pm:3505> INFO - No sort tailoring available for locale 'en-US'

[3227] bbl.pm:608> INFO - Writing 'output.bbl' with encoding 'UTF-8'

[3429] bbl.pm:712> INFO - Output to output.bbl

The issue is particularly difficult to troubleshoot as it only occurs when I compile the full document, and that takes several minutes.

  • Did you try to use \nocite{*} ?
    – murray
    Oct 20, 2020 at 15:05
  • I'm not sure what that is, what is it supposed to do? Adding it into my text didn't do anything.
    – MrMere
    Oct 20, 2020 at 15:36

2 Answers 2


Well I never figured out the real issue, but I solved whatever it was by changing my biblatex backend to bibtex rather than biber.


Just in case anyone else was also has this issue - in my case it turned out that a whitespace in a file name causes this. Everything else compiles just fine so I wasn't really focused on that, but if the citations are in a text file that has a whitespace in the title they won't show up!

  • 1
    I think you mean "a text file that has a whitespace in the file name". In this context, "title" may be misinterpreted as the title of something in the text. Jun 16 at 14:59
  • @barbarabeeton I think, your comment belongs to the answer of Víctor Souza Barboza below.
    – dexteritas
    Jun 16 at 16:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .