19

I use beamer class with newcent package for the font. I set

\documentclass[8pt]{beamer}

at the top of my tex file. But I think the font is still too large.

In my beamer theme, I tried to set :

\setbeamerfont{normal text}{size=\small}

But it does not work and I think that it is not the correct way to do that.

How can I globally reduce the font size ?

Thanks

21

According to section 18.2.1 of the beamer manual, a default font size of 8pt is already "way too small". beamer uses the extsizes packages for non-standard font sizes, and extsizes doesn't offer anything smaller than 8pt. If you really must fit more text on each frame, I suggest to enlarge beamer's paper size from 128mm*96mm to, say, 140mm*105mm.

\documentclass[8pt]{beamer}

\geometry{paperwidth=140mm,paperheight=105mm}

\usepackage{lipsum}

\begin{document}

\begin{frame}
\lipsum[1]
\end{frame}

\end{document}

enter image description here

EDIT: Another option is to load the scrextend package (part of KOMA-Script) which allows to choose arbitrary font sizes like 7.5pt -- be sure to use a vector font like Latin Modern.

\documentclass{beamer}

\usepackage{lmodern}

\usepackage{scrextend}
\changefontsizes{7.5pt}

\usepackage{lipsum}

\begin{document}

\begin{frame}
\lipsum[1]
\end{frame}

\end{document}

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.