0

I'm getting the following error message compiling my PhD-file (used: LuaLaTeX, MikTeX 2.9):

! TeX capacity exceeded, sorry [save size=500000].
<to be read again> 
\relax 
l.90    \include{M02Part02}
                       
If you really absolutely need more capacity,
you can ask a wizard to enlarge me.



Here is how much of LuaTeX's memory you used:
 44238 strings out of 479059
 125007,2373549 words of node,token memory allocated 3836 words of node memory still in use:
   14 hlist, 3 vlist, 4 rule, 31 disc, 2 local_par, 3 dir, 56 glue, 5 kern, 5 pe
nalty, 4 margin_kern, 277 glyph, 139 attribute, 97 glue_spec, 22 attribute_list,
 1 temp, 7 if_stack, 1 write nodes
   avail lists: 1:7,2:3461,3:167,4:63,5:660,6:73,7:11166,8:2,9:753,10:32,11:1490
,12:1
 62526 multiletter control sequences out of 65536+200000
 83 fonts using 27566143 bytes
 94i,19n,112p,10600b,499999s stack positions out of 5000i,500n,10000p,200000b,500000s
!  ==> Fatal error occurred, no output PDF file produced!

It's quite impossible (and maybe not even necessary) to give you a MWE, because I'm compiling a dozen of files by the include command. The error occurs since I'm using the reledparpackage to create a translation (latin on the left, german on the right) including some index commands and footnotes. I wonder why TeX is 'already' overloaded, because I just wanted to have two or three pages as an output for testing. But, as I read in some other posts, the size of the document as a whole does not cause an error normally. Often, the solution is only: "Use LuaLaTeX!", what I'm already doing!

So... Neither this Problems by enlarging tex memory nor this Compiler error "save size exceeded" nor even this TeX capacity exceeded despite system call LuaLaTeX did work for me. Increasing the memory or the save size didn't have any consequences. I already have the shell-escape included in TeXstudio, and until the recent usage of the reledpar package, I didn't have any problems with it.

Please help!

Update I reduced my files step by step. There was no error with the reledpar package in my opinion, because everything worked fine until I included my (large) bibliography created with biblatex. I suppose that this could overload TeX because I added quite a lot of adaptions of the style. Maybe that there is to find this coding error mentioned in the commentaries.

Update 2 I managed to compile my files in a normal way by putting only the .tex-files in a new folder, open it an compile it.

Update 3 - MWE I created a MWE in order to see if you get the same errors. Yesterday it worked quite properly. But since today morning, the problem is something with the line numbers, I suppose: Everytime, the compiling is working once, producing a PDF in which the lineation isn't correct, but index and bibliography are created correctly (in the log: Please rerun LaTeX). During the second run, I get the "save-size" warning. I hope the MWE works. I didn't reproduce the structure of my document which I'm creating with front-, main- and backmatter, but I included all the options which I consider important for the problem (and its solution, maybe??). I excluded biblatex which is definitely not causing the error, for better overview.

\documentclass[paper=a4, twoside=true, usegeometry, fontsize=12pt, parskip=false, 
captions=signature, 
headings=small, headings=optiontoheadandtoc, chapterprefix=true, appendixprefix=true,
numbers=noendperiod, BCOR=0.5mm, DIV=calc, headinclude=true, footinclude=true, pagesize=auto, 
headsepline=0.25pt, footsepline=false, footbotline=0.25pt, plainfootbotline=true, titlepage=true, 
toc=listof, toc=index, toc=bibliography, toc=graduated, listof=chapterentry, nonumberline, 
chapterentrydots=true, sectionentrydos=true, cleardoublepage=empty, open=right]{scrbook}

% Schrift
\usepackage{microtype} % Verbesserung des Satzspiegels und des Satzes
\usepackage{unicode-math} % lädt auch fontspec mit (Voß Wiss. Arb. S. 30)
\usepackage[utf8]{inputenc} % direkt ä, ö etc. von der Tastatur eingeben

\usepackage{lipsum}
% Sprache
\usepackage[french, italian, english, ngerman]{babel} % ngerman als Hauptsprache
\usepackage[autostyle=true, french=guillemets, english=american, german=quotes]{csquotes}

%Index
\usepackage[splitindex,xindy]{imakeidx}
% reledpar/reledmac

\usepackage[nocritical, noeledsec, noend, noledgroup, series={A}]{reledmac}
\usepackage[advancedshiftedpstarts, nomaxlines]{reledpar}
\renewcommand*{\ledlsnotefontsetup}{\raggedleft\tiny}% left
\renewcommand*{\ledrsnotefontsetup}{\raggedright\tiny}% right
\newcommand{\memorybreak}{\pausenumbering\resumenumbering}

\begin{document}
\chapter{some chapter}
\begin{pages}
\begin{Leftside}\beginnumbering\numberpstarttrue
\pstart[\section{Steph. Doletus Gulielmo Scaevae, s.}]
\ledouternote{Gryph. 3} Vberrimum ad te scribendi argumentum dum undiquaque colligo, \& diutius, quam sperabas, sileo, tuam forte de meo in te amore atque singulari beneuolentia opinionem mirum in modum fallo, neque tardi aut parum diligentis nomen non subeo: sed si qua istiusmodi suspicionem tibi mea tam longa taciturnitate\index{some index} commoui, diligentiam adhibebo, illam ut quam primum\footnoteA{some footnote} deleam.
\pend\endnumbering
\end{Leftside}
\begin{Rightside}\beginnumbering
\numberlinefalse % keine Nummerierung in der Übersetzung
\pstart
some translation
\pend\endnumbering
\end{Rightside}
\end{pages}
\Pages
\printindex
\end{document}
8
  • 3
    "save size exceeded" almost always mean there is a coding error somewhere. Try to make a small example which uses more than a few hundred from the "s" values (499999s). See also tex.stackexchange.com/a/134599/2388 – Ulrike Fischer Oct 21 '20 at 14:50
  • 1
    My bet is that one (or maybe two (or maybe just M02Part02)) is causing the problem. Try including only a few, and see if you still have the problem. – Teepeemm Oct 21 '20 at 14:52
  • @Teepeemm You're right that this file causes the error. If I don't include it, I don't get the error. This is clear, because only in this file, the environment pages of the reledpar package is used. – Bastian Wagner Oct 21 '20 at 15:00
  • @UlrikeFischer Sorry for this question, but where can I find these values? If I find them, I will create a MWE. – Bastian Wagner Oct 21 '20 at 15:00
  • 2
    Ok I'll try to create a MWE (probably until tomorrow) which shows the error for you. – Bastian Wagner Oct 21 '20 at 15:25
0

Once I had a project with many, very large, tikz graphs (lualatex MikTex 2.9, win10 x64, 8GB RAM) and I ran into a a similar problem.

I edited the file

texmfapp.ini

C:\Program Files\ MiKTeX\ miktex\config

Finally everything worked with these values

main_memory = 79999999

save_size = 79999

extra_mem_bot = 79999999

extra_mem_top = 79999999

font_mem_size = 799999

pool_size = 7999999

buf_size = 7999999

stack size = 200000

max-strings = 79999999

It was trial and error. At the time I did not find the log output very useful. Maybe setting max-string alone is enough for you.

I didn't have similar problems with the new MiKTex version so far, but I didn't try to recompile the old project, so for now I'm keeping the default values. Good luck!

If you really absolutely need more capacity, you can ask a wizard to enlarge me.

Not my case, but maybe it helps if you submit only the (actual) part of your document that seems to be the cause of the problem, skipping the rest, but keeping the class, settings, and packages you are using.

4
  • max-strings won't help. save_size would except that the OP already has 500000 so more than the 79999 you suggest above. – David Carlisle Oct 21 '20 at 16:53
  • @ David Carlisle I already confessed my ignorance. – Simon Dispa Oct 21 '20 at 16:57
  • 2
    no it's the right answer (or the similar texmf.cnf for texlive) just the numbers need to be bigger (although most likely the document is in a loop and no number is big enough, it is hard to use that much save stack) – David Carlisle Oct 21 '20 at 17:03
  • Thanks for these options: I'll try it. Yet I can tell (and I will put this in an update to my question) that I managed to compile my files normally after deleting ALL the automatically created files (.bbl, .aux etc.) and put all the tex-files of my project into a new folder. – Bastian Wagner Oct 22 '20 at 15:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.