The package repository shows that the packages can be installed from internet. But I need it to be installed from random package repository. How can I change it

Please help me

  • 2
    Please add to your question which distribution you use (texlive, miktex, mactex, ...)
    – Martin H
    May 21, 2012 at 14:44
  • I use MixTex2.8
    – Vidhya
    May 21, 2012 at 14:48
  • As I couldnt instal packages from random package repository, I clicked on install from internet. But later on I instaled the packages and now I need to change the repository. Please tell me the path which should be browsed to change the repository
    – Vidhya
    May 21, 2012 at 14:50

2 Answers 2


You can use the package manager for that. However, I would recommend you to update to MikTeX 2.9 if possible.

enter image description here

Then you can go to the Repository Menu and select Change Repository option.

enter image description here

After clicking next if you wish to have it updated from internet, you would get the list of available repositories.

enter image description here

Note that, an available repository can be offline temporarily such that you can't download packages or update them.

  • Sir.. from the second dialog box i need to select second option and i need the path to b browsed for that.. i don want it to be installed from net because i hav already installed package in my system
    – Vidhya
    May 21, 2012 at 15:15
  • @Vidhya That's also a possibility. You can also use the MikTeX update option to access these menus. Is there any further difficulties that I didn't understand from your comments?
    – percusse
    May 21, 2012 at 15:18
  • thank u soooo much......it worked....i have been behind this for a week..really cracked my head
    – Vidhya
    May 21, 2012 at 15:31
  • i used the package to right align the chapter but now the contents, list og figures etc also aligned right..i used \chapterfont{\raggedleft} code...
    – Vidhya
    May 21, 2012 at 15:33
  • @Vidhya You should ask that as a new question with a minimum and compilable code such that others can have a look too.
    – percusse
    May 21, 2012 at 16:02

Miktek version 4.3 (20220313)

for me worked this way (ssl error 35):

deactivate proxy

try different repos, until you can see the list of packages

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .