0

I try to compile a document with shell-escape and pdflatex. But everytime I want to start compiling, my compiler does not even start. The logs do not show any error... I enabling shell-escape the way it is mentioned here: https://tex.stackexchange.com/a/99476

I use Texstudio with Texlive on a Linux Mint 20/Ubuntu 20 Machine. Before that I used the same compiler (and editor) on Debian and I had no Problem compiling with shell-escape.

I try to compile this document: https://github.com/Stefanqn/Bewerbung

Hope someone can help me.

4
  • Welcome to TeX SX! Did you write --shell-escape or shell-escape?
    – Bernard
    Oct 22, 2020 at 9:05
  • Thank you! I write --shell-escape
    – Wind8000
    Oct 22, 2020 at 9:06
  • What happens if you compile from the command line?
    – Bernard
    Oct 22, 2020 at 9:08
  • LaTeX Warning: File 'anschreibenGen.tex' already exists on the system. Not generating it from this source. This is pdfTeX, Version 3.14159265-2.6-1.40.20 (TeX Live 2019/Debian) (preloaded format=pdflatex) restricted \write18 enabled. entering extended mode ! I can't write on file 'anschreibenGen.log'. It asked me to enter another filename, but after that it tells me also, it could not write on it. I found out, that the build-dir was not existing so I created that dir. After that it compiled via shell with no problems.
    – Wind8000
    Oct 22, 2020 at 9:18

1 Answer 1

0

Well, I still cannot compile with Texlive/Texstudio, but I made myself a workaround:

The original Problem is, that there was no build-dir, which the compiler does not create, but the tex-file wanted. So I created it manually (Watch the privileges!) and run pdflatex --shell-escape Bewerbung_Komplett.tex from shell inside the Main-File-Dir.

Or to conclude: It was just my own idiocy. :'D

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.