3

I would like to display ligatures in a text set with Times New Roman, using LuaLaTeX to compile. I have tried \setmainfont[Ligatures=Common]{Times New Roman} as well as Ligatures=TeX. Both seem to be ignored. The ligature glyphs are installed on my system.

In an older answer I saw that I can manually map the ligatures (Ligatures for fi, fl, ffl do not work for Times New Roman (XeLaTeX)). However, I was wondering if this has become simpler in 2020.

MWE:

\documentclass{scrartcl}

\usepackage{fontspec}

\setmainfont[Ligatures=TeX]{Times New Roman}

\begin{document}

office fit fluent

o{f}{f}ice {f}it {f}luent %to display text without ligatures

\end{document}

1 Answer 1

7

For some unknown reason times puts these ligatures under dlig. So use the Rare option. Braces don't suppress ligatures, use \/

\documentclass{scrartcl}

\usepackage{fontspec}

\setmainfont{Times New Roman}[Ligatures=Rare]

\begin{document}

office fit fluent ---

o{f}{f}ice {f}it {f}luent %doesn't work to display text without ligatures

of\/fice f\/it f\/luent %to display text without ligatures

\end{document}      

enter image description here

6
  • That did it, thanks! How do I find out which option I need to use for which font?
    – C.Carl
    Oct 30, 2020 at 15:11
  • 1
    I used otfinfo --script=latn -f times.tff to check the features and then guessed. Oct 30, 2020 at 15:18
  • I'll try that, although I might not be as lucky in guessing :)
    – C.Carl
    Oct 30, 2020 at 15:24
  • 1
    After 10 or 20 wrong guesses you will get the hang on it. It is mostly training. (The fontspec docu contains some explanations about the features). Oct 30, 2020 at 15:38
  • I note also that the TeX Gyre Termes version of Times New Roman does these ligatures correctly without any [Ligatures=...] option.
    – Thruston
    Oct 30, 2020 at 23:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.