0

When combining the memoir class and the thumbs package, the trim marks (i.e. crop marks) are no longer displayed.
updated MWE:

\documentclass[showtrims,a4paper]{memoir}
\usepackage{blindtext}
\usepackage{xcolor}

%%%%%%%%%%%%%
\setpagecc{240mm}{167mm}{*}
\setlrmarginsandblock{10mm}{15mm}{*}
\setulmarginsandblock{22mm}{10mm}{*}
\setheadfoot{2mm}{0mm}
\setheaderspaces{10mm}{*}{1}
\setmarginnotes{0mm}{0mm}{0mm}
%%%%%%%%%%%%%
\checkandfixthelayout
%%%%%%%%%%%%%
%edge index
\usepackage{thumbs}
%%%%%%%%%%%%%

\begin{document}
    \mainmatter
    \chapter{This is a chapter title}
    \addthumb{}{\thechapter}{black}{black!10}
    \Blindtext
\end{document}

After applying pdflatex, the PDF looks like this: 1. page

2. page

I would greatly appreciate your help!

4
  • When I pdflatex your MWE the trim marks are displayed but no thumb marks. I also tried changing the class from memoir to book (commenting out memoir specific code) but no thumb marks were displayed. I assumed that you wanted bot trim and thumb marks. Please provide an MWE that shows your problem. – Peter Wilson Oct 31 '20 at 18:54
  • The use of memoir is essential for the document I want to typeset. The example code was is that regard minimal, that loading the package thumbssuffices to disable the crop marks. I added the code, that actually inserts the chapter edge index and provided the PDF result I get after pdflatex. If I remove \usepackage{thumbs} (and \addthumb{}{\thechapter}{black}{black!10}) the crop marks are visible. – Grohana Nov 2 '20 at 8:49
  • As Peter I don't get the images you post using TeXLive 2020. – daleif Nov 2 '20 at 8:58
  • Good point. I don't run TeXLive, but I updated my MiKTeX distribution and that did the trick! Thank you both! – Grohana Nov 3 '20 at 16:49
0

As it turned out, my local version of the memoir package (and maybe of some dependent packages) wasn't up to date. Running updates in the MiKTeX console fixed it.

1
  • Note, it is a good idea to use @name when your comment is directed to a certain person, then they'll get notified – daleif Nov 3 '20 at 17:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.