0

in the output PDF file there are some unwanted red/green unterlines:

enter image description here

And all over the contents:

enter image description here

I am using latex workshop 8.13.2 on Vscode and I can't find the relevant setting. How could I disable the annoying spell check?

(Ps. I don't want to turn off the spell check for the source code. The problem is in the generated PDF file.)

Thanks!

1
  • 5
    That's not spell check, those are hyperlinks made by hyperref. Try \hypersetup{hidelinks} before \begin{document}. Commented Nov 2, 2020 at 18:58

1 Answer 1

1

You probably have pdfborderstyle={/S/U/W 1} somewhere in your document (or in a template file you are using), which makes underlined links, according to the hyperref manual:

Links can be underlined instead of the default rectangle or options colorlinks, frenchlinks. This is done by option pdfborderstyle={/S/U/W 1}.

Either replace that by hidelinks, or if you can't find it, add \hypersetup{hidelinks} in your preamble as @PhelypeOleinik said. Here's a sample code for you to play with:

\documentclass{article}
\usepackage{hyperref}
\bibliographystyle{unsrt}
% \hypersetup{pdfborderstyle={/S/U/W 1}} % <-------- You have
\hypersetup{hidelinks} % <-------- You want
\begin{document}
\tableofcontents
\section{Intro}\label{sec}
\cite{article-full}, see section~\ref{sec}.
\bibliography{xampl}
\end{document}

The output, as promised, without underlining:

enter image description here

1
  • Amazing! I added "hidelinks" to \hypersetup{} and problem solved. Commented Nov 2, 2020 at 20:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .