1

I am really noob with LaTeX, and I am running into an issue with an index:

In the .ind / .idx files, spaces are added to some entries, for a reason I cannnot figure. For instance, while the .tex file has

\index[IndexInterp]{\textbf{Bethsames }! domus ueri solis}

in the .ind file this entry becomes:

\item \textbf  {Bethsames }
\subitem  domus ueri solis, 279

As a result, this entry does not appear in the right place according to the alphabetical order.

I would be grateful if you had a way to fix this. I work with TeXWorks on Windows 10, and typeset with XelateX

5
  • Welcome to tex.sx. This q&a may help: tex.stackexchange.com/q/412517 Commented Nov 12, 2020 at 0:37
  • Thank you @barbarabeeton adding \string seems to have solved the issue! I still don't understand why those strings appeared though, because contrary to the poster in this example I had not redefined the \index command.
    – Marjorie
    Commented Nov 12, 2020 at 4:12
  • as always your question would be clearer if you had provided an example that demonstrated the problem.I would guess that you have used \index in the argument of another command. Also, you have redefined \index somewhere despite your comment above, the standard \index command does not have an optional argument. Commented Nov 12, 2020 at 7:58
  • @DavidCarlisle -- An optional argument is characteristic of imakeindex. And a very nice option it is. (Don't know whether it's what's relevant here; as you said, no example to tie it down.) Commented Nov 12, 2020 at 16:37
  • @barbarabeeton there are probably a dozen packages extending index and most give index an optional argument, but we shouldn't have to guess which is used Commented Nov 12, 2020 at 16:38

0

You must log in to answer this question.

Browse other questions tagged .