1

I'm using Texpad to write a book chapter. This is a review so the bibliography is very large. I'm using BiBDesk to generate my bib file. After working on the chapter my references started showing up as question marks and I get this error in the log file: "Sorry---you've exceeded BibTeX's pool size 100000". I've tried manually changing the pool size in /usr/local/texlive/2020/texmf.cnf but this is a read only file and it won't allow me to increase the pool size. If I split my book chapter into two parts then my references show up again, but this is not ideal as then I'll have to manually stitch the bibliography together somehow. Are there any suggestions for an easier way to increase the pool size so my references show up?

Here's what my latex setup is:

\documentclass{nature}
\usepackage[semicolon,numbers]{natbib}
\setcitestyle{authoryear,open={(},close={)}}

\begin{document}
% ------------------------------------------------
% - content
%---------------------------------------------------------------------------------------
\newpage
\begin{center}
\section*{References} 
\vspace{-17pt}
\end{center}
\bibsection
\bibpreamble
\bibliographystyle{apa} % bst file 

\bibliography{example.bib} % bib file 

\end{document}
1

A couple thoughts: If you can use biber/BibLaTeX I think that the hard-coded pool size limit doesn't apply. There is a BibLaTeX apa style that may do the trick.

Depending on your platform, there may be a bibtex8 program which has command line options to increase the capacity. You could do bibtex8 --big or --huge or --wolfgang depending on your needs. It's entirely possible, incidentally that your bibtex command is aliased to this or has similar options available (try typing bibtex -? and see what happens. My laptop is in for repairs right now so I can't easily check the state of things on my own.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.