0

I am struggling with following:

I work on a larger collection in LaTeX, which includes around 30 different papers. I am used to work on macOS (Texpad - currently using live compiler), hence compiling via MacTeX. However, it does not produce files such as .aux, .bbl, .log, .out etc. and most importantly, supporting file generated by the template I have to use to set page numbering and order for each article.

After correction I have to recompile each article under Windows (using TeXStudio) to obtain necessary files. Is there a way to achieve this in macOS (I use Mac for all of my other work-related things and it becomes very unpleasant to need both systems).

  • 1
    All TeX implementations produce the .aux file, etc. Are you using a nasty IDE which automatically deletes them? – Ian Thompson Nov 16 at 15:30
  • 1
    Check the command your editor is using to compile your code. Perhaps it's hiding aux files, or deleting them. Like @IanThompson said, all TeX distributions produces these files. – Héliton Martins Nov 16 at 15:34
  • 2
    Looking at the TeXPad documentation here it hides .aux files by default, but you can change this in the preferences. – Alan Munn Nov 16 at 15:38
  • 1
    Then the question may be better aimed at the TeXpad support people, rather than here. – Alan Munn Nov 16 at 15:39
  • 2
    I haven't used TeXpad, but I suspect that the presence of a .texpadtmp directory is sufficient to hide the files independent of the preference setting. If that's the case, try deleting all the aux files and recompiling and see if they appear, and failing that, delete the .texpadtmp directory entirely and then recompile. – Alan Munn Nov 16 at 15:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.