My problem is as follows. I have many drawings with mathematical symbols. Only after the compilation of the last two there is a problem. On all other mathematical symbols are incorrectly displayed and the font changes from the Times to the Computer Modern.

Any ideas how to solve it?


  • I'm not sure I understand your question. Are the fonts ok after one compilation and then change after another compilation? How were the problematic figures generated? This looks as though the font isn't properly embedded in the EPS.
    – Alan Munn
    Commented May 24, 2012 at 23:03
  • All figures were made in the MPEdit (.PS) (dvi -> ps). They were created as a PS and then as EPS (GSview: PS to EPS). They look fine after compilation (.PDF: latex -> dvi2ps -> ps2pdf). I made next figure in this same method. After joining the last figure to the source file (.TEX) and re-doing the compilation, all the figures, except the last one, are incorrect.
    – Przemek
    Commented May 24, 2012 at 23:54
  • Problem solved. The first figures I did with MiKTeX 2.8. Next in MiKTeX 2.9. The difference is the version of MetaPost and key files (mp.exe vs mpost.exe). When I made the old figures in the new version, everything is alright.
    – Przemek
    Commented Jun 27, 2012 at 0:32
  • I'm glad you solved your problem. You should turn your comment into an answer. It's fine to answer your own questions, and having an answer will get the question off of our "unanswered questions" list. (You may need a little more reputation to add the answer.)
    – Alan Munn
    Commented Jun 27, 2012 at 0:41


Browse other questions tagged .