0

I have Win10 with Lyx 2.3. However, I cannot reconfigure and it fails with the following error:

the system reconfigure has failed. Default reconfiguration is used but lyx may not be able to work properly. Please reconfigure again if needed

I caught the error log, and it is stated the following:

14:24:45.602: Reconfiguring...
14:24:45.643: python -tt "C:/Program Files (x86)/LyX 2.3/Resources/configure.py" --with-version-suffix=2.3 --binary-dir="C:/Program Files (x86)/LyX 2.3/bin/"
14:24:46.820: checking for DVI to DTL converter...
14:24:46.820: +checking for "dv2dt"...  yes
14:24:46.820: checking for DTL to DVI converter...
14:24:46.820: +checking for "dt2dv"...  yes
14:24:46.820: checking for a Latex2e program...
14:24:46.820: +checking for "latex"...  yes
14:24:46.820: checking for a DVI postprocessing program...
14:24:46.820: +checking for "pplatex"...  yes
14:24:46.820: checking for pLaTeX, the Japanese LaTeX...
14:24:46.836: +checking for "platex"...  no
14:24:48.340: checking for a java interpreter...
14:24:48.340: +checking for "java"...  no
14:24:48.340: checking for a perl interpreter...
14:24:48.355: +checking for "perl"...  yes
14:24:48.355: Traceback (most recent call last):
14:24:48.355:   File "C:/Program Files (x86)/LyX 2.3/Resources/configure.py", line 1853, in <module>
14:24:48.355:     (inkscape_path, inkscape_gui) = os.path.split(checkInkscape())
14:24:48.355:   File "C:/Program Files (x86)/LyX 2.3/Resources/configure.py", line 516, in      checkInkscape
14:24:48.355:     return str(val[0]).split('"')[1]
14:24:48.355: IndexError: list index out of range
14:24:48.355: Recargando configuración...LyX: reconfiguring user dir
support/Systemcall.cpp (294): Systemcall: 'python -tt "C:/Program Files (x86)/LyX 2.3/Resources/configure.py" --with-version-suffix=2.3 --binary-dir="C:/Program Files (x86)/LyX 2.3/bin/"' finished with exit code 1
LyX: Done!

14:24:50.232: (reconfigure)

I suspect that there's a problem with python. Anybody knows how to solve this issue?

6
  • How urgent is this? The reason I ask is that there is a new LyX version (2.3.6) being prepared for release and I think it will be available within a few days. There's a chance it will fix this bug. If it is more urgent than that, I suggest you contact the lyx-users list.
    – scottkosty
    Nov 30, 2020 at 15:52
  • Are documents developed in LyX 2.3 editable by higher LyX versions?
    – galtor
    Nov 30, 2020 at 16:13
  • Any document created by any 2.3.x version is editable by a 2.3.y version, for any x and y. They use the same format. When LyX 2.4.0 is released, it will use a new format. It can edit any document created by an older version of LyX, but things a bit trickier if you want to edit a document created in 2.4.0 by LyX 2.3.x. Let me know if you want more details on this.
    – scottkosty
    Nov 30, 2020 at 22:15
  • by the way, LyX 2.3.6 was just released and is available for download.
    – scottkosty
    Nov 30, 2020 at 23:55
  • Thanks. My problem was solved with that version.
    – galtor
    Dec 2, 2020 at 8:36

1 Answer 1

0

Finally, I updated my Lyx version to 2.3.6 and the error was solved.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .