1

I am writing a report in Lyx. I always have problem with wrap figure. I have a lot of white space under it, like on figure and don't know how to solve. In wrap figure settings I put: Placement: Outer (default) Width: 40 column width % not checked overhang and line span. Thanks in advance.

enter image description here enter image description here

1
  • 1
    What about check line span, set some value like "20" and according to the result, reduce or enlarge that value?
    – Fran
    Dec 6 '20 at 19:38
0

I didn't know there was a gui for wrapfig arguments!

The wrapping is based on counting lines (because \parshape), and the counting can be thrown off both by vertical space (as before Primedba) and by larger equations (those bigger than three lines of paragraph text). That's when you have to use the line-count argument.

Sorry it is hard to count (hypothetical ordinary) lines in such a situation! You could measure your image and divide that by the line spacing. Using wrapfig with the [verbose] option should report the line count, since it is easier to adjust a previous value than to count the whole size.

A trick is to temporarily put

Wrapping \arabic{WF@wrappedlines} lines.

after \end{wrapfigure}, and read the value from the output.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.