I installed current TexLive afresh on a new HD under Devuan beowulf. The file I've been working on has \usepackage{siunitx) in preamble, but after with the re-installation when I run latex on it under emacs I get: Error: File `siunitx.sty' not found. I realized I had not copied the TeX packages from my old disk to the new.

So I ran $ tlmgr --gui and do "Load Default" from the ctan mirror. But get error: "Loading of remote database failed. Error message: Remote repository is newer than local (2018 < 2020)". The problem this is I'm running TeXLive 20200731. Two years ago I did run the 2018 version.

So I proceed to update my database by downloding and unzipping update-tlmgr-latest.sh. I do have /bin/sh. Here is what I get:

Verifying archive integrity... All good. Uncompressing TeX Live Manager Updater 100% ./runme.sh: Cannot find TeX Live root using kpsewhich --var-value=SELFAUTOPARENT. ./runme.sh: (no tlpkg/texlive.tlpdb and/or tlpkg/tlpobj/.) ./runme.sh: Please set your PATH as needed, otherwise it's hopeless.

I try $ tlmgr update --self (running on Debian, switching to user mode!) tlmgr: Remote repository is newer than local (2018 < 2020) Cross release updates are only supported with update-tlmgr-latest(.sh/.exe) --update Please see https://tug.org/texlive/upgrade.html for details.

The configuration:

(running on Debian, switching to user mode!) ===================== version information ======================= tlmgr revision 49885 (2019-01-31 20:27:00 +0100) tlmgr using installation: /usr/share/texlive ... PATH: /usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games ... kpsewhich: /usr/bin/kpsewhich ... TEXCONFIG={{}/home/haines/.texlive2018/texmf-config,/home/haines/... ... == kpathsea variables from environment only (ok if no output here)

So it seems my TeXLive as 2018. In /home/haines there is no longer any .texlfive directory. In ~/.profile there is:

PATH=/usr/local/texlive/2020/bin/x86_64-linux:$PATH; export PATH

  • PATH=/usr/local/texlive/2020/bin/x86_64-linux:$PATH would be the default location for a vanilla texlive installed from TUG, running on Debian, switching to user mode implies that you are using a debian packaged texlive (which should be updated with apt packages not tlmgr. Do you have two conflicting installations? Commented Dec 10, 2020 at 0:03

2 Answers 2


If you installed TeX Live through apt, it updates through apt, not tlmgr. You might have more than one TeX Live installation in your PATH. Check which tlmgr to find out which one you are actually running. Also check the version you installed, using apt show texlive-base.

If you installed your own, up-to-date version, you want to make sure it is in your PATH and remove the others. There are instructions here.

You also would not want to run tlmgr from your user account in any case. You should create a tex system account (or texlive) and run your installers and updates as that. You should, however, be running programs like lualatex and latex without sudo.

  • I did full deletion of TeXLive and resinstalled carefully. Now linux command not in PATH. So I do: $ /usr/local/texlive/2020/bin/x86_64-linuIx$ ./pdftex sample2e.tex This is pdfTeX, Version 3.14159265-2.6-1.40.21 (TeX Live 2020) (preloaded format=pdftex) restricted \write18 enabled. entering extended mode ! I can't write on file sample2e.log'. (Press Enter to retry, or Control-D to exit; default file extension is .log') Commented Dec 10, 2020 at 21:30
  • @HainesBrown I’m not able to understand your comment. Sorry.
    – Davislor
    Commented Dec 10, 2020 at 21:32
  • Simply that with the full install with the downloaded installer .gz file I I can no longer run the $ latex command. Because the failure of my TeXLive to work it is interfering seriously with my work, I'm temped to do another removal and just install the stable texlive-full from my operating system repository. Any reason I shouldn't? Commented Dec 10, 2020 at 21:36
  • @HainesBrown There’s a typo in the path you gave x86_64_linulx, which might be the problem. Just adding the command PATH=/usr/local/texlive/2020/bin/x86_64-linux:$PATH to your profile ought to work; I linked to directions that might be more complicated than what you need.
    – Davislor
    Commented Dec 10, 2020 at 21:47
  • That said, sudo apt install texlive-full ought to work fine with less effort.
    – Davislor
    Commented Dec 10, 2020 at 21:48

Finally had success. The problem I had testing Tex Live by issuing a latex command was because foolishly I did not log out/in to make the paths defined in .profile operative. Have no idea the reason for the original problem except that somewhere there was a link that presumed an earlier version of TeX Live. I did a radical cleansing of my old installation of TeX Live and downloaded the installer again in order to reinstall.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .