1

I have a document here of document class "Article(Standard)". And as you can see in the image below, Lyx is not splitting long concatenated words and therefore they are reaching out on the side.

No Hyphenation for concatenated word

How can I fix this?

5
  • By default LaTeX will break words containing a hyphen (-) character only at the hyphen(s) and nowhere else. See tex.stackexchange.com/q/2706/35864, tex.stackexchange.com/q/63232/35864, texfaq.org/FAQ-nohyph.html for a few workarounds.
    – moewe
    Commented Dec 24, 2020 at 11:19
  • The word "tert-butyl-(S)-(2-oxo-1-phenyl-2-(piperidin-1-yl)ethyl)carbamate" has lots of hyphens. But why doesn't LaTeX split this word at any of the available hyphens?
    – wewa
    Commented Dec 24, 2020 at 11:24
  • The last bit without hyphens (yl)ethyl)carbamate) is quite long, so maybe it can't be moved to the next line without leaving too much space in the previous line. I'm also not too sure about the impact of the parentheses on the line breaking.
    – moewe
    Commented Dec 24, 2020 at 11:30
  • Experimented a bit: At least with English and the default settings, the round brackets are no problem. As mentioned above LaTeX will break the word only at the hyphens
    – moewe
    Commented Dec 24, 2020 at 11:43
  • 1
    I searched a bit and found tex.stackexchange.com/a/218118/231568 which suggests to use chemmacros and iupac.
    – wewa
    Commented Dec 24, 2020 at 12:17

2 Answers 2

2

bingung already posted the answer to question here: https://tex.stackexchange.com/a/218118/231568.

The above mentioned word is a IUPAC nomenclature and the package chemmacros is providing the necessary functionality for hyphenation of those words. Therefore simply \usepackage{chemmacros} to include the package and use \iupac{\textit{tert}-butyl-(S)-(2-oxo-1-phenyl-2-(piperidin-1-yl)ethyl)carbamate} to "write" the word. The picture below shows that this is working. enter image description here

0

There’s a great answer by @wewa (Welcome to the site!). Two other tips to reduce the need for hyphenation are to \usepackage{microtype} (in LuaLaTeX or PDFLaTeX, which support font expansion) and increasing the allowed interword spacing for really ugly paragraphs with \emergencystretch 3em.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .