1

I am using natbib and the apacite style. I want to cite Descartes' Meditations, and one standard way of doing it involves an in-text citation of the form '(CSM 25)'. I managed to use the alias system to get '(CSM, 25)', but I don't know how to remove the comma. Is there a way to remove the comma to get '(CSM 25)'? The following is my code for the citation followed by my code for the .bib file:

\defcitealias{Meditations}{CSM}
\citepalias[][25]{Meditations}


@book{Meditations,
  author = {Rene Descartes},
  year = {1985},
  title = {The Philosophical Writings of {Descartes}, Vol. 2},
  translator = {John Cottingham and Robert Stoothoff and Dugald Murdoch},
  publisher = {Cambridge University Press},
  originalyear = {1641},
  address     = {Cambridge},
}

Thank you.

2
  • Welcome to TeX.SE. Please provide more information about your document, including the document class , any citation management packages, and the bibliography style you employ. (Aside: the apacite bibliography style should be used alongside the apacite citation manatement package.) Please also clarify what the number 25 in \citepalias[][25]{Meditations} denotes: a page number? something else? – Mico Dec 30 '20 at 8:39
  • The document class is 'report'. The citation packages are: \usepackage[natbibapa]{apacite} \bibliographystyle{apacite} The number 25 is for the section number. It is in the margin and covers 1-2 paragraphs. It is distinct from the page number. I had to switch to natbib from apacite because apacite wasn't allowing me to do multiple authors in an in-text citation with their own page numbers. I'm sticking to this package now. – Sikander Dec 31 '20 at 16:47
1

Since you use the apacite citation management package with the option natbibapa, you can issue a directive such as \setcitestyle{notesep={ }} to change the separator between the (aliased) citation callout and the subsequent note.

enter image description here

\documentclass{article} 
% using 'article' rahter than 'report' to keep all output on the same page

\begin{filecontents}[overwrite]{mybib.bib}
@book{Meditations,
  author       = {René Descartes},
  year         = {1985},
  title        = {The Philosophical Writings of {Descartes}, {Vol.~2}},
  translator   = {John Cottingham and Robert Stoothoff and Dugald Murdoch},
  publisher    = {Cambridge University Press},
  originalyear = {1641},
  address      = {Cambridge},
}
\end{filecontents}

\usepackage[natbibapa]{apacite}
\bibliographystyle{apacite}
\defcitealias{Meditations}{CSM}
\setcitestyle{notesep={ }} % default separator string is ", "

\begin{document}
\citepalias[25]{Meditations}
\bibliography{mybib}
\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.